Can't Connect to Wireless Network

So i have an ASUS GT-AC5300 router, which is a triband. Manjaro KDE and XFCE both seem unable to connect to the third band wireless connection(5Ghz-2). My brother who was using the Gnome variant was able to connect just fine, so I’m wondering what issue is preventing me from being able to connect to that specific network.
It is a hidden network, though I did try unhiding it, but even with that it still didn’t show up and manually connecting to it fails. I tried lowering the channel bandwidth to no avail. So I’m at a bit of a loss as to what’s causing the issue. I’m kinda new to the Linux scene(transferred from windows as I got fed up with OS problems), so maybe I’m missing something really simple and I just don’t realize it.
To clarify, the other two networks, 2Ghz and 5Ghz-1, work just fine along with ethernet also working.

Hi @GigaPain ,
Welcome to the forum!
Could you post the following terminal command, in order to give you any advice?
``ìnxi -Fazy```

Please, read this post before answering.
How to provide good information


Well here is the information that the command spat out.

Hi @GigaPain ,
Please, take a look at this post. I wonder whether you could solve the problem.
Asus PCE-AC88 3100 - slow wifi & trouble reconnecting after restart/boot - #5 by minskiz
I think you could try another drivers, as @minskiz wrote on the post.

Hope this help. Regards,

Thanks, was just what I was looking for. Everything works now.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.