Can't connect to network using ethernet or by using wireless adapter

I am a noob at linux so please make it sound simple for me to understand.I liked the way manjaro looked so I downloaded manjaro KDE plasma and dual booted it with windows 11.When I am using windows 11 I always use ethernet.When i was installing manjaro i was using ethernet but it said in the installer that you are not connected to a network.I ignored that and i installed manjaro.For the first time when I booted in to manjaro it said that i am connected to a network but cannot acess internet.So i tried using a wifi adapter coz my motherboard dosen’t have built in wifi.But that also didn’t work as it said no available networks.Then i tried it on windows and the wifi adapter seems to be working fine on windows 11.Then i hopped back in to manjaro and tried usb tethering and it worked fine.I used that to search the forums for a fix.In one forum someone was recommending to go check my drivers so I did.My network driver was in open source so i installed it.After that i disconnected usb tehering and plugged my ehternet back.And now it didnt even say that it was “connected to a network but couldnt connect to internet”.Then i unistalled it and reinstalled the driver again and again but it didnt work.I typed this commandinxi -Nazy to check my ethernet type and here are the results.

  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASRock driver: N/A modules: r8169, r8168 pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8168
    class-ID: 0200

what were the commands used for installing/removing the ethernet driver?

i didint use commands.i went to system settings and then hardware configuration.then selected my drive which said open source.I right clicked it and pressed install.this was all done by usb tethering connection

post output from:
mhwd -l -li

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI
         network-r8168            2016.04.20                true            PCI

Warning: No installed USB configs!
> 0000:03:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
                  NAME               VERSION          FREEDRIVER           TYPE
         network-r8168            2016.04.20                true            PCI

> 0000:01:00.0 (0300:10de:1401) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2021.11.04               false            PCI
    video-nvidia-470xx            2021.11.04               false            PCI
    video-nvidia-390xx            2021.11.26               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

ok, you have installed the ethernet driver, so reboot and then post full system info:
inxi -Fazv7

  Kernel: 5.15.60-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=bce12070-3f4c-4fd6-8c11-083fffd494c0 rw quiet
  Desktop: KDE Plasma v: 5.24.6 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1
    dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASRock model: H110M-HDV serial: <superuser required>
    UEFI-[Legacy]: American Megatrends v: P7.60 date: 02/26/2018
  Message: No system battery data found. Is one present?
  RAM: total: 15.59 GiB used: 1.19 GiB (7.7%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges
  Info: model: Intel Core i5-7400 bits: 64 type: MCP arch: Kaby Lake
    gen: core 7 built: 2018 process: Intel 14nm family: 6 model-id: 0x9E (158)
    stepping: 9 microcode: 0xF0
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
    desc: 1x6 MiB
  Speed (MHz): avg: 800 min/max: 800/3500 scaling: driver: intel_pstate
    governor: powersave cores: 1: 800 2: 800 3: 800 4: 800 bogomips: 24008
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush
    clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu
    fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ida
    intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor
    movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm
    pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand rdseed rdtscp
    rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp
    syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi
    vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT disabled
  Type: retbleed mitigation: IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, RSB filling,
    PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GM206 [GeForce GTX 960] vendor: ZOTAC driver: nouveau
    v: kernel non-free: 515.xx+ status: current (as of 2022-07) arch: Maxwell
    code: GMxxx process: TSMC 28nm built: 2014-19 pcie: gen: 1
    speed: 2.5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s ports:
    active: DVI-I-1 empty: DP-1,DVI-D-1,HDMI-A-1 bus-ID: 01:00.0
    chip-ID: 10de:1401 class-ID: 0300
  Device-2: Generalplus GENERAL WEBCAM type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 1-7:4 chip-ID: 1b3f:2247
    class-ID: 0102
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,vesa gpu: nouveau display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: DVI-I-1 model: Sanyo LED MONITOR serial: <filter> built: 2011
    res: 1920x1080 hz: 60 dpi: 102 gamma: 1.2 size: 477x268mm (18.78x10.55")
    diag: 547mm (21.5") ratio: 15:9, 16:9 modes: max: 1920x1080 min: 720x400
  OpenGL: renderer: NV126 v: 4.3 Mesa 22.1.6 direct render: Yes
  Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASRock
    driver: snd_hda_intel v: kernel bus-ID: 1-7:4 chip-ID: 1b3f:2247
    bus-ID: 00:1f.3 chip-ID: 8086:a170 class-ID: 0102 class-ID: 0403
  Device-2: NVIDIA GM206 High Definition Audio vendor: ZOTAC
    driver: snd_hda_intel v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16
    link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.1 chip-ID: 10de:0fba
    class-ID: 0403
  Device-3: Generalplus GENERAL WEBCAM type: USB
    driver: snd-usb-audio,uvcvideo
  Sound Server-1: ALSA v: k5.15.60-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.56 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASRock driver: N/A modules: r8169, r8168 pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  WAN IP: No WAN IP found. Connected to web? SSL issues? Try enabling dig
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 1.13 TiB used: 480.34 GiB (41.6%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: KingDian model: S280 240GB
    size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 7A scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WD10EZEX-22MFCA0 size: 931.51 GiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
    rev: 1A01 scheme: MBR
  Optical-1: /dev/sr0 vendor: ATAPI model: DVD A DH16A6L rev: ZH39
    dev-links: cdrom
  Features: speed: 12 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
  ID-1: / raw-size: 146.48 GiB size: 143.13 GiB (97.71%) used: 8.76 GiB
    (6.1%) fs: ext4 dev: /dev/sdb3 maj-min: 8:19 label: N/A
    uuid: bce12070-3f4c-4fd6-8c11-083fffd494c0
  ID-2: /run/media/zapaxe/50C660F5C660DCAA raw-size: 222.86 GiB size: 222.86
    GiB (100.00%) used: 188.84 GiB (84.7%) fs: ntfs dev: /dev/sda3
    maj-min: 8:3 label: N/A uuid: 50C660F5C660DCAA
  ID-3: /run/media/zapaxe/Dilith raw-size: 492.06 GiB size: 492.06 GiB
    (100.00%) used: 245.48 GiB (49.9%) fs: ntfs dev: /dev/sdb1 maj-min: 8:17
    label: Dilith uuid: 8CF8958AF89572E6
  ID-4: /run/media/zapaxe/Rajith raw-size: 292.97 GiB size: 292.97 GiB
    (100.00%) used: 37.26 GiB (12.7%) fs: ntfs dev: /dev/sdb2 maj-min: 8:18
    label: Rajith uuid: A04EFB8D4EFB5B0C
  Alert: No swap data was found.
  ID-1: /dev/sda1 maj-min: 8:1 size: 100 MiB fs: vfat label: N/A
    uuid: 8A55-343B
  ID-2: /dev/sda2 maj-min: 8:2 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-3: /dev/sda4 maj-min: 8:4 size: 611 MiB fs: ntfs label: N/A
    uuid: 5C260AA9260A846C
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 10 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-5:2 info: YK 2.4G Wireless Device type: Mouse,Keyboard
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 1.5 Mb/s
    power: 100mA chip-ID: 3938:1080 class-ID: 0301
  Device-2: 1-7:4 info: Generalplus GENERAL WEBCAM type: Video,Audio
    driver: snd-usb-audio,uvcvideo interfaces: 4 rev: 2.0 speed: 480 Mb/s
    power: 100mA chip-ID: 1b3f:2247 class-ID: 0102
  Device-3: 1-9:5 info: China Resource Semico Usb Mouse type: Mouse
    driver: hid-generic,usbhid interfaces: 1 rev: 1.1 speed: 1.5 Mb/s
    power: 98mA chip-ID: 1a2c:0044 class-ID: 0301
  Hub-2: 2-0:1 info: Super-speed hub ports: 4 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 41.0 C pch: 44.5 C mobo: N/A gpu: nouveau
    temp: 48.0 C
  Fan Speeds (RPM): N/A gpu: nouveau fan: 291
  Processes: 188 Uptime: 3m wakeups: 0 Init: systemd v: 251
  default: graphical tool: systemctl Compilers: gcc: 12.1.1 clang: 14.0.6
  Packages: pacman: 1172 lib: 316 flatpak: 0 Shell: Zsh v: 5.9 default: Bash
  v: 5.1.16 running-in: konsole inxi: 3.3.20

the driver was loaded, otherwise you wouldnt see this :arrow_down:… now its no longer loaded, since you messed with it…

check in bios if fast boot is disabled - you may not have this option;
and in windows fast startup needs to be disabled, if its not, disable it

Also i have to say that the ssd where windows is installed is a gpt or UEFI drive and the drive where manjaro is installed is a mbr or legacy drive.

why would you do that, if you can use uefi/gpt? … but check the fast boot and the fast startup, and disable them

I disabled fast boot in bios fast startup in windows.I didnt install manjaro in the ssd beacause it was a 256GB ssd and i had 1TB of free space on normal hard drive

ok, but that you are on mbr is not related…
so after you disabled them, check again with:
inxi -N
to see if the ethernet driver is loaded

this is the response

  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: N/A

not loaded, have no idea what happened here, since it was working previously …
run this:
sudo modprobe r8169
did this loaded the driver?

i entered the command it it didnt do anything but now my it is saying it is connected to a network but can connect to internet.

ok so it loaded the driver… so now in system settings/network/connections/wired connection/ipv4 set up your dns/address/netmask/gateway, click apply

can you tell me how to add my dns

select the method as ‘manual’, and in dns servers type your provider dns, or use cloudflare dns: or quad dns:

Now my ethernet works but its really slow.i used quad dns as my dns

and how is the speed with is it better?
and did you set up everything else, your ip, mask, gateway?
go to the ipv6 tab, and under method disable it, and see if it helps