Can't connect the usb file transferring from phone to desktop!

I am having problem with the connectivity with my android phone to laptop. Everytime when I put the plug in and select the option which pop up on my phone screen to file transfer, I can’t show the file on my laptop. There’s been showing that can’t fine the file or something.

Thank you

Have a look into this guide:

What’s the exact error message?

No storage media found. Make sure your device is unlocked and has MTP enabled in its USB connection settings

What’s the output of lsusb while it’s connected?

File transfer

No, the output from the terminal running the lsusb command.

Bus 003 Device 013: ID 04e8:6860 Samsung Electronics Co., Ltd Galaxy A5 (MTP)
( I am not the OP but same problem and same answers.)

I’m having similar problems also, but for me lsusb doesn’t recognize my phone at all.
Phone: Samsung Galaxy Note 8 running Android 9.
PC: ASUS X555L running Manjaro i3.
I installed mtpfs and jmtpfs, gvfs etc, but unsurprisingly that didn’t fix the problem.
The phone is in developer mode, unlocked, with connection set to MTP.
Tried connecting on USB3 and USB2 ports.
Also tried connecting the phone while running a Windows virtual machine on the same PC, which didn’t detect the phone either.
Any ideas?

Probably the cable is defective or incompatible (because of USB 2.0?).

For me there are two different cables, one cable does not work, other cable works fine.

1 Like

You were absolutely right. Switching to another cable solved my problem. Thanks!