Can't change locale after installation either


#1

I have the same problem as mentioned in this thread. For the life of me, I can’t change the locale of my fresh, hours old, Manjaro OpenRC/Cinnamon install through the Manjaro Settings Manager.

I have succesfully installed 2 languages: nl_NL and en_US. When I make any change to the locale settings in the Settings Manager, the changes disappears the moment I hit apply. No setting will stick.

I have not yet hit the lucky situation where somehow, through no reproducible set of actions, my settings will stick.

Is something crucial missing from my Cinnamon minimal install? Anyone got a clue?


Manjaro settings in Khmer or something, can't read
#2

Do you have a ~/.pam_environment file? If so, move/delete it.


#3

No, haven’t got that file.


#4

Just because I reinstalled choosing en_US instead of nl_NL at installation time. No change in behavior, can’t change locale settings at all.


#5

Output of locale and cat /etc/locale.conf ?


#6

locale

LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

cat /etc/locale.conf

LANG="en_US.UTF-8"

According to the previous thread, I tried adding all the LC_ settings manually to /etc/locale.conf, but that did not make any difference.

Also my system has no /etc/default/locale file.


#7

OK, so it’s not using MSM but:

  1. Edit /etc/locale.conf to your preferred locale (nl_NL.UTF-8)
  2. Edit /etc/locale.gen and make sure nl_NL.UTF-8 is uncommented
  3. Run sudo locale-gen

That should switch your system over to nl_NL. If you want to do it on a per-user basis:

  1. Edit /etc/locale.gen as above
  2. Run sudo locale-gen
  3. Create a new file $HOME/.pam_environment with the content:
  1. Log out and back in.

NOTE: I haven’t tested this with anything other than en_GB.UTF-8 but it should work the same for nl_NL.


#8

Thanks @jonathon! I had tried those things on the previous install and tried them now again on this fresh install.

There is no ~/.pam_environment file generated when I run sudo locale-gen. The locale is not changed. I can’t even change it when I switch to another TTY. And yes, the en_US and nl_NL locales have been uncommented.

So I can’t change the locale at all, it stays at whatever I choose at installation time.

My goal is to use the Locale Details tab, to set my OS to en_US and have my formats in nl_NL.

I start to wonder if this is an OpenRC issue @eugen-b?


#9

Settingsmanager doesn’t support openrc, you could try installing openrc-settingsd and see if this helps.


#10

Correct. I said to create the file. :wink:


#11

Well, that explains something! :wink:

Anyway, I can change the locale by running locale-gen, however logging out and in of the DE is not enough. I have to actually reboot.

Now I wonder what I should edit to set the different locale parameters (LC_NUMERIC etc.) by hand…


#12

Ah, succes! Following this post, I used /etc/profile to export the detailed locale settings.

Now it looks like:

LANG=en_US.UTF-8
LC_CTYPE=en_US.UTF-8
LC_NUMERIC=nl_NL.UTF-8
LC_TIME=nl_NL.UTF-8
LC_COLLATE=nl_NL.UTF-8
LC_MONETARY=nl_NL.UTF-8
LC_MESSAGES=en_US.UTF-8
LC_PAPER=nl_NL.UTF-8
LC_NAME=nl_NL.UTF-8
LC_ADDRESS=nl_NL.UTF-8
LC_TELEPHONE=nl_NL.UTF-8
LC_MEASUREMENT=nl_NL.UTF-8
LC_IDENTIFICATION=nl_NL.UTF-8
LC_ALL=

closed #13

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.