Can't change brightness on Asus Zephyrus


I’m having a problem where I can’t change the brightness on my Asus Zephyrus. Even when I modify


directly, it does nothing. It was working before when I was on Ubuntu 17.04 using the default desktop(unity?).

I’m on kernel 4.14, but I tried 4.13 as well
Nvidia driver 384.90

Any help is appreciated!


It might be that some patch in Ubuntu kernel makes it work, or that it needs some different kind of interface.

Could you try installing light from AUR, and trying to set brightness with it?


you could use different grub options. this is mine (asus zenbook pro)

GRUB_CMDLINE_LINUX_DEFAULT=“quiet acpi_osi=’!Windows 2015’ acpi=force acpi_enforce_resources=lax drm.vblankoffdelay=1 acpi_backlight=intel iwlwifi.swcrypto=1 elevator=deadline”


@Chrysostomus Installed light but it doesn’t seem to affect anything. I don’t think it’s a kernel thing because switching to gnome on Ubuntu produces the same problem. It seems only unity from ubuntu seems to allow me to switch brightness.

@mac I tried some of your settings, it doesn’t seem to affect the brightness. I also tried acpi_backlight=vendor, again nothing.

If nothing works, I suppose I’ll just have to move back to Ubuntu in the meantime.