Can't browse reddit on firefox

Whenever I try to browse reddit, page elements load messy and I can only scroll for 4-5 posts.

I’m running firefox 84.0.2 on Manjaro Linux KDE (did the latest stable update).

I tried deleting the cache, it works half of the time and only for a single session, then things go back to their broken state. I’ve tried ‘safe mode’ as well, but things didn’t change at all…
Also I tried to post something (actually this very topic) but I can’t either. So it’s pretty unusable!

Anyone has an idea what other thing(s) I could try to fix this?

Works fine for me. Do you have enough of RAM?
Show inxi -Fazym

I don’t usually use FF for Reddit. But just tried it and it seems fine. Are you sure that FF is the problem - the Reddit site seems to be a bit flaky lately.

Are you running some extensions that interact with the web page?
Make sure Javascript is NOT disabled in your browser.

1 Like

That’s extremely weird, have you tried using the ‘old’ reddit?

Really sounds like you’ve got to have some jank extentions or something making a mess.

1 Like

Yeah but then safe mode with extensions disabled should have corrected the bug, ain’t it?

Sure thing, here it is. But if 16Gb of RAM + Swap can’t handle reddit…

  Kernel: 5.10.7-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=c9136c9f-47f5-4078-8d4c-af348b4a9581 rw quiet udev.log_priority=3 
  threadirqs resume=/dev/disk/by-uuid/c9136c9f-47f5-4078-8d4c-af348b4a9581 
  Desktop: KDE Plasma 5.20.5 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Laptop System: LENOVO product: 24295F3 v: ThinkPad T530 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: LENOVO model: 24295F3 serial: <filter> UEFI [Legacy]: LENOVO 
  v: G4ET93WW (2.53 ) date: 02/22/2013 
  ID-1: BAT0 charge: 38.0 Wh condition: 73.9/86.6 Wh (85%) volts: 11.3/11.1 
  model: LGC 45N1011 type: Li-ion serial: <filter> status: Discharging 
  RAM: total: 15.34 GiB used: 1.98 GiB (12.9%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Quad Core model: Intel Core i7-3840QM bits: 64 type: MT MCP 
  arch: Ivy Bridge family: 6 model-id: 3A (58) stepping: 9 microcode: 21 
  L2 cache: 8 MiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44719 
  Speed: 1197 MHz min/max: 1200/3800 MHz Core speeds (MHz): 1: 1197 2: 1248 
  3: 1699 4: 1339 5: 1443 6: 1470 7: 1359 8: 1409 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds status: Vulnerable: No microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Lenovo driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:0166 
  Device-2: Acer ThinkPad Integrated Camera type: USB driver: uvcvideo 
  bus ID: 1-1.6:6 chip ID: 5986:02d2 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: 
  loaded: intel unloaded: modesetting alternate: fbdev,vesa display ID: :0 
  screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: LVDS1 res: 1920x1080 hz: 60 dpi: 143 size: 340x190mm (13.4x7.5") 
  diag: 389mm (15.3") 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) 
  v: 4.2 Mesa 20.3.3 compat-v: 3.0 direct render: Yes 
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:1e20 
  Sound Server: ALSA v: k5.10.7-3-MANJARO 
  Device-1: Intel 82579LM Gigabit Network vendor: Lenovo driver: e1000e 
  v: kernel port: 5080 bus ID: 00:19.0 chip ID: 8086:1502 
  IF: enp0s25 state: down mac: <filter> 
  Device-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi 
  v: kernel port: efa0 bus ID: 03:00.0 chip ID: 8086:0085 
  IF: wlp3s0 state: up mac: <filter> 
  Device-3: Ericsson Business Mobile Networks BV H5321 gw Mobile Broadband 
  type: USB driver: cdc_acm,cdc_mbim,cdc_wdm bus ID: 3-4:2 chip ID: 0bdb:1926 
  serial: <filter> 
  IF: wwp0s20u4i6 state: down mac: <filter> 
  Local Storage: total: 489.05 GiB used: 143.58 GiB (29.4%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT525MX300SSD1 
  size: 489.05 GiB block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: R060 
  ID-1: / raw size: 100 GiB size: 97.93 GiB (97.93%) used: 25.56 GiB (26.1%) 
  fs: ext4 dev: /dev/sda5 maj-min: 8:5 
  ID-2: /home raw size: 375.19 GiB size: 294.29 GiB (78.44%) 
  used: 118.02 GiB (40.1%) fs: ext4 dev: /dev/sda6 maj-min: 8:6 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: file size: 8 GiB used: 0 KiB (0.0%) priority: -2 
  file: /swapfile 
  System Temperatures: cpu: 46.0 C mobo: 0.0 C 
  Fan Speeds (RPM): cpu: 0 
  Processes: 276 Uptime: 1m wakeups: 1 Init: systemd v: 247 Compilers: 
  gcc: 10.2.0 Packages: pacman: 1458 lib: 479 Shell: Bash v: 5.1.0 
  running in: konsole inxi: 3.2.02

I’m adding this screenshot. We can see that the scroll bar on the right is at its bottom, a post with the image not loading and the last post cut in half.

@Greggex it works just fine in chromium, so I suppose it’s FF related, but it might be something else…

@exo how can I check if Javascript is disabled? I didn’t purposely deactivated it, but who knows?

Uncheck these, save. You’d think reddit couldn’t be more cancer, but with the ‘new’ bloated site they certainly managed it.

Second this.
Revert back to old design and install “Reddit Enhancement Suite” extension for better experience. It takes some time to get used to but it is so much better than the new design.

Mmh, I can’t even access my settings on ff, and in chromium the only beta-related option is already unchecked…

Check " Opt out of the redesign"

Btw new design seems to work fine for me.

Close Firefox, rename it’s folder (use Dolphin or do mv .mozilla mozilla) and restart Firefox.

Well, on such a matter, always first list the add-ons:

grep -oP '},"name":"\K[^"]+' ~/.mozilla/firefox/*.*default*/addons.json