Can't boot Windows 10 in QEMU, only flashing cursor

I’m trying to do a Windows 10 install on qemu, but I only get a quick Windows logo flash and then I’m stuck on a flashing cursor (I left it running for 10+ minutes and it didn’t work). On top I see qemu-system-x86_64 using 100% CPU, however.

Thinking my old ISO might be corrupted, I downloaded a new one from Microsoft and still the problem persists.

My command line is qemu-system-x86_64 -cdrom ./Win10_21H2_BrazilianPortuguese_x64.iso -drive file=Windows10.qcow2,format=qcow2 -m 8192 -vga std -enable-kvm -boot menu=on, but even without any parameters (i.e. qemu-system-x86_64 -cdrom ./Win10_21H2_BrazilianPortuguese_x64.iso -m 2048) I still get the same problem.

With the same settings (only replacing the ISO), I can successfully boot a Linux image (Fedora 36 live-CD), which makes me think the problem is Windows.

I am using qemu version 6.2.0 on Fedora 36. Both ISO and hard drive image are on a NVMe SSD. What am I missing here?


maybe virt-manager will help you :wink:

I also use it, my linux kernal version is 5.19, when i downgrade it to 5.15, this problem is solved. Although I don’t know what exactly causes that

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.