Can't boot Manjaro XFCE on ASUS TUF Gaming FX504GM-E4353

I cant boot Manjaro XFCE on ASUS TUF Gaming FX504GM-E4353 with acpi_osi='Windows 2018'. Previous related thread ASUS TUF Gaming FX504GM-E4353

Screenshots if acpi_osi='Windows 2018' :


Have you tried instead of that to use acpi_osi=Linux nouveau.modeset=0 when booting from Live Media install?

2 Likes

I try

Boot loaded. And installed manjaro. Thx very very very ... great!!! What i need to do for normal start system before restart after install?

You can add the same command inside /etc/default/grub on the line GRUB_CMDLINE_LINUX_DEFAULT
For instance if you have:

GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=92853c68-c459-45b9-b9fd-8f0676e1f678 resume_offset=5980160 udev.log_priority=3"

where of course the UUID is the one on your machine, NOT the one i provided, you modify it like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_osi='Linux' nouveau.modeset=0 resume=UUID=92853c68-c459-45b9-b9fd-8f0676e1f678 resume_offset=5980160 udev.log_priority=3"

Then you run from terminal:
sudo update-grub

Double check, and if you are unsure, share that line as it is and as is when modified before you reboot ... Probably that line will not be needed on the installed system, but also will do no harm.

Also, just in case, make sure you look at the options you have to set the GPUs

2 Likes

I installed nvidia with command in terminale: sudo mhwd -i pci video-nvidia
Reboot laptop. And manjaro no works. Black screen.


What to do?

Is that cursor blinking? Can you access a TTY by pressing Ctrl+Alt+F3 for instance?

1 Like

Yes. I got this

// started doing it https://github.com/dglt1/optimus-switch . just before doing this, i had to install the driver (sudo mhwd -i pci video-nvidia). didn't think a glitch would happen.
My comp has nVidia GeForce GTX 1060 (3 GB), Intel® UHD 630 (because CPU: Intel Core i5 8300H)

Have you updated the system before that? If not, just do it now and maybe you will be able to log in the desktop. Log in as you user from that TTY screen and run this command:
sudo pacman-mirrors -f5 && sudo pacman -Syyu
When it finishes, reboot the system with:
systemctl reboot
For Optimus Switch you had to go trough all the commands there and configurations before rebooting the system. :slight_smile: Lesson learned now, i hope.
You can still follow the Optimus Switch how to from that TTY, but make sure the system is updated first.

2 Likes

System was updated before nvidia driver.

1 Like

maybe it was necessary to remove the pre-installed driver before installing nvidia?
I remembered something

Yes, you have to follow that exactly. Most likely you had to do:
sudo mhwd -r pci video-linux
then
sudo mhwd -i pci video-nvidia
and everything else after that, exactly as described.

1 Like

Ok. Thx great again! I go to reinstall Manjaro.

i confused. should me change here something?

I am doing this point:

Apparently you have the same ID as described and used in that config/script. You don't have to change anything, just do the rest of the steps. :wink:

2 Likes

Ok. :wink:

Reboot and have black screen. What this mean?

Not sure. Can you access TTY (for example Ctrl+Alt+F3 to get to TTY3) ? If yes, then log in and do this command as your user:
sudo systemctl enable haveged --now
then switch back to TTY1 by Ctrl+Alt+F1 and see if you can access the desktop. If not we have to see what went wrong and maybe we can ping @dglt for a bit of assistance (hope you don't mind) :slight_smile:

1 Like

If ctrl+alt+f1

Go back to TTY3 and reboot from there by this command:
systemctl reboot
If hangs in the same place, then we have to see the status of lightdm and eventually what happens if using startx.

1 Like