Can't boot Manjaro xfce after Powercut

I can’t boot Manjaro xfce after Powercut. It shows the following message:

mount: /new_root: can’t read superblock on /dev/sda1
You are now being dropped into an emergency shell.
sh: can’t access tty; job control turned off
[rootfs ]#

It happens to me a lot because in my society, there are lot of power cuts. That’s why I know that we have to make a bootable usb and run fsck. So ,for this ,I made a permanent bootable usb. But for a reason, that bootable usb is gone and I am stuck. I do not have any other computer to make a bootable usb.

Please help if you can.

As far as I know
you can run the fsck on that device right from that emergency shell
Did you try that?
If you did - what happened?

I tried that but it said
Fsck: command not found

I also checked in sbin directory if there is fsck file
But there was not

The exact output was:
sh: fsck: not found

If that happens a lot to you, i suggest using a filesystem that is resistant to power failures. Some filesystems use “copy on write” or “journaling” .These will not easily be damaged.
On power loss then you may loose some changes on documents that did not reach the filesystem, but the filesystem will not break.

There has been such fs’s for years now. For example jffs2 (for RAW flash). We used this on 30.000 devices where the user just unplugs the device instead of properly shutting down linux.
In newer devices we use btrfs (for flash with controller) instead. Btrfs won’t break, and will need no fsck to repair. It will automatically revert to the last functioning checkpoint at boot.

Check this post to see if fsck can fix the problem.

If not, then your disk may be unfortunately corrupted permanently.

Here’s another article about using backup superblock.

If all of those measures don’t work, the final extreme measure is to apply mke2fs -S option to override the superblock descriptor.

-S     Write  superblock and group descriptors only.  This is an extreme measure to be taken only in the very unlikely case that all of the superblock and backup superblocks are corrupted, and a last-ditch recovery method is desired by ex‐
              perienced users.  It causes mke2fs to reinitialize the superblock and group descriptors, while not touching the inode table and the block and inode bitmaps.  The e2fsck program should be run immediately after this  option  is  used,
              and  there  is  no guarantee that any data will be salvageable.  Due to the wide variety of possible options to mke2fs that affect the on-disk layout, it is critical to specify exactly the same format options, such as blocksize, fs-
              type, feature flags, and other tunables when using this option, or the filesystem will be further corrupted.  In some cases, such as filesystems that have been resized, or have had features enabled after format time, it is  impossi‐
              ble to overwrite all of the superblocks correctly, and at least some filesystem corruption will occur.  It is best to run this on a full copy of the filesystem so other options can be tried if this doesn't work.

DO NOT DO THIS UNLESS OTHER MEASURES DON’T WORK! This is how I damaged my disk permanently and why I rebuild my system :sweat:

in your initial ramdisk
(which is what is booted now, the emergency shell is the limited environment it provides)
fsck isn’t included

It would be included if you had the “fsck” HOOK in /etc/mkinitcpio.conf
For some reason you didn’t.
You should have …
… but there is nothing that can be done about that now, though …

Without booting the system from an external device
(the USB thumb drive which you don’t have)
there is nothing you can do to attempt to fix the problem.

Get one - create it on another computer and then fix yours with it.
Nothing else will help …

What filesystem where you using?
ext4 is usually pretty fault tolerant
it will usually “fix itself” after sudden shutdowns like this.

Perhaps your disk is bad.
If and when you get it running again - check it thoroughly (SMART data).