Can't boot manjaro on intel nuc 8i7hvk

Hello everyone, I have an Intel NUC 8i7hvk. When I installed the latest manjaro-kde-18.0.4, I failed.

After selecting boot manjarol, the screen was black, and then the radiator turned very fast. I searched for some posts. Most people said that it was a graphics card driver problems, but did not find a good solution.

I have seen almost the same problem before. It is here. https://forum.manjaro.org/t/solved-can-t-boot-manjaro-on-intel-nuc-8i7hvk/49957

I have successfully installed and started kubuntu on some methods on the network, but manjaro is not.

Looks like you did not disable ‘secure boot’ as EgLe has reminded you.
You must reinstall with ‘secure boot’ disabled.
And use the $esp in your nvme disk (nvme0n1p1) and do not format this during installation.

Note that Ubuntu can be installed with ‘secure boot’ enabled, but not Manjaro.

ps: I also did not see your fstab of your installed Manjaro OS.
(your output is of the livecd OS)

I have the option to disable the safe boot, otherwise the first boot interface will not be able to enter.
And how to set $esp? Why can’t I format it? These are not the same as my previous installation process.

It must be ‘secure boot’ that should be disabled, not ‘safe boot’.
Find the term ‘secure boot’ at the bios. Not ‘safe boot’. Disable it.
Your ‘efibootmgr -v’ shows an entry for Manjaro and Ubuntu that has the indication of an enabled ‘secure boot’ (meaning using ‘shim’) for your installations.

See if you can boot up your installed Manjaro using [More Complicated Setups]. If you can, we can try to fix it.

BTW, can you try to see if you get to the /etc/fstab of your installed Manjaro OS (not livecd OS).

Because if you use the $esp in nvme, it will the same as the same as windows. If you format it during installation, it will erase your windows boot and we do not want that.

I many of the forum posts, users are unable to use $esp outside of nvme disk and have to change to using nvme $esp to make it work. Yours might be similar.

I just typed a typo, I disabled the secure boot before. The ‘secure boot’ information you see for ubuntu is because I have to ‘secure boot’ when I install ubuntu. After the installation is confirmed, I disabled ‘secure boot’.

And the hard drive has been covered many times, I don’t know why ubuntu information is still there, but it is not the real system information.

Thank you for your reply. I will try your suggestion tomorrow.

Hello @ShawnFeng

on My NUC i have install, Windows 10, Manjaro and Debian Buster.
I dont have “enable Secureboot” any Time.

For Secureboot the distributions have to pay licenses.
Ubuntu has such a license but the secureboot does not have to be activated.

On my NUC i disable Secureboot, and i install New Windows 10 Debian-Buster and Manjaro without Secureboot.

And if you take the same Bios settings like me, so you can boot from USB-Stick with no Grub-Setting if you used a Kenel 4.18 or Higer…

I have set up 2 identical NUC 8i7HVK of this kind in this way.

Thank you @EgLe
What is “boot from USB-Stick with no Grub-Setting”?
And how to “no Grub-Setting”?
And why?

Thank you @gohlip
My grub is available, isn’t it? So why do I need those? I can boot the installed manjaro, but it stops here

Understand. Good question too. So it looks like a graphic thing then (which I’m no good at).
But let’s try to rule out a few things to check if that is a graphics thing.

  1. Try to boot to prompt (no graphics) and use fallback (no modules, no microcode).
    At grub menu choose fallback entry and press ‘e’ (to edit) and add ‘3’ (no apostrophes) to the linux line. So it looks like
		linux	/boot/vmlinuz-4.20-x86_64 root=UUID=2b259af0-f5c5-4b3d-a2f6-19f1d83ee208 rw  3
		initrd	/boot/initramfs-4.20-x86_64-fallback.img

If it boots to prompt, good and login with password and do

sudo pacman-mirrors -f3
sudo pacman -Syyuu
sudo mkinitcpio -P
  1. Then after (1) is successful, login again to prompt, full kernel (not fallback)
		linux	/boot/vmlinuz-5.0-x86_64 root=UUID=2b259af0-f5c5-4b3d-a2f6-19f1d83ee208 rw  3
		initrd	/boot/intel-ucode.img /boot/amd-ucode.img /boot/initramfs-5.0-x86_64.img
  1. If (2) is successful, boot normally, (no prompt)

Let us know if how it goes. But if it is a graphic thing, others here will have to help you but provide

inxi -G
mhwd -l
mhwd -li

ps: While I may not be able to help on graphics, try to change to ‘free’ graphics if non-free in installed. And I find it better if we do ‘pacman -Syu’ between removing and installing drivers.
So like

sudo mhwd -r pci video-nvidia  (remove all listed, including vesa, if there)
sudo pacman -Syu
sudo mhwd -i pci video-linux
sudo pacman -Syu

Good luck.

Hello @ShawnFeng

today I downloaded the current Manjaro-KDE 18.04 and made it on a USB stick.
Then I booted from it and selected and started the non-free drivers in the boot menu. This went without problems and I landed in the KDE desktop.

The Same Thing is when i boot with the Option “driver=free”…

I think that you have more problems with the bios or the bios settings?

PS. This posting is writing under manjaro-kde-18.0.4-stable-x86_64.iso booting from USB-Stick.

[manjaro@manjaro ~]$ inxi -F
System:    Host: manjaro Kernel: 4.19.28-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.15.2 Distro: Manjaro Linux 
Machine:   Type: Desktop System: Intel product: NUC8i7HVK v: J71485-501 serial: <root required> 
           Mobo: Intel model: NUC8i7HVB v: J68196-401 serial: <root required> UEFI: Intel v: HNKBLi70.86A.0048.2018.0725.1749 
           date: 07/25/2018 
CPU:       Topology: Quad Core model: Intel Core i7-8809G bits: 64 type: MT MCP L2 cache: 8192 KiB 
           Speed: 800 MHz min/max: 800/4200 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Polaris 22 [Radeon RX Vega M GH] driver: amdgpu v: kernel 
           Display: x11 server: X.Org 1.20.4 driver: amdgpu FAILED: ati unloaded: modesetting resolution: 2560x1440~60Hz 
           OpenGL: renderer: AMD VEGAM (DRM 3.27.0 4.19.28-1-MANJARO LLVM 7.0.1) v: 4.5 Mesa 18.3.4 
Audio:     Device-1: Intel CM238 HD Audio driver: snd_hda_intel 
           Device-2: Advanced Micro Devices [AMD/ATI] Polaris 22 HDMI Audio driver: snd_hda_intel 
           Sound Server: ALSA v: k4.19.28-1-MANJARO 
Network:   Device-1: Intel Ethernet I219-LM driver: e1000e 
           IF: eno1 state: down mac: d4:5d:df:07:4d:2d 
           Device-2: Intel I210 Gigabit Network driver: igb 
           IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: d4:5d:df:07:4d:2e 
           Device-3: Intel Wireless 8265 / 8275 driver: iwlwifi 
           IF: wlp6s0 state: down mac: f6:c5:9f:a5:50:de 
Drives:    Local Storage: total: 4.10 TiB used: 131.4 MiB (0.0%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO 500GB size: 465.76 GiB 
           ID-2: /dev/sda type: USB vendor: Seagate model: ST4000DM000-1F2168 size: 3.64 TiB 
           ID-3: /dev/sdb type: USB vendor: Transcend model: JetFlash Transcend 8GB size: 7.14 GiB 
Partition: ID-1: / size: 11.71 GiB used: 131.4 MiB (1.1%) fs: overlay source: ERR-102 
Sensors:   System Temperatures: cpu: 39.5 C mobo: 29.8 C gpu: amdgpu temp: 38 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 232 Uptime: 3m Memory: 15.62 GiB used: 1.35 GiB (8.6%) Shell: bash inxi: 3.0.32 
[manjaro@manjaro ~]$ 

Thank you for your patience.
I found my problem!
My process is exactly the same as you, bios is also. Except that I am using my USB type-c connection to my monitor. Yes, this is the problem! I switched to the HDMI cable and now I have no problems.

Manjaro’s installation interface is not output to USB type-c by default!
But other systems like Windows/Kubuntu/Ubuntu are fine. I think this is also a bug or problem with Manjaro?

My monitor is connected with USB type-c. I started to suspect the connection line a few days ago, but I am not sure, and there is no HDMI cable at home, so I have not found the problem.

Thank you @gohlip @EgLe, you helped me gradually rule out other reasons for the problem.

1 Like

@Ste74

Do you want to look into this? Thanks.

Any workaround is appreciated… or a tip where we can look into it

I have no idea. Sorry. Don’t know if ShawnFeng has any pointers for us.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark