Can't boot Manjaro LiveCD

#1

I was getting an error while booting a new computer that worked with Windows and Ubuntu (which were subsequently wiped by the company that provided the computer, on my request): sp5100_tco: i/o address 0x0cd6 already in use. See https://youtu.be/97SU49Y6jYk. However, as per https://bbs.archlinux.org/viewtopic.php?id=125482, I appended module_blacklist=sp5100_tco to the linux line in the Grub boot parameters, and did not see the error while booting. However, I still have the same problem as previously, where the last line of the boot loader is [ OK } Reached target Graphical Interface but then just goes to a new blank screen with the underscore flashing. (Pressing Alt+F1 takes me back to the boot log, with the above line and the flashing underscore prompt.)

mkinitcpio -M still lists sp5100_tco.

I tried adding install sp5100_tco /bin/false in /etc/modprobe.d/blacklist.conf,

Ah, I didn’t regenerate the initramfs, I’ll try again. It seems like I don’t need to do that via the bootloader. However, maybe it’s being loaded by other modules.

#2

It seems like video driver issue. What graphics card do you have? Have you tried to boot with free/nonfree drivers?

#3

The GPU is an ASUS RTX 2080 Turbo 8 GB GDDR6. The ASUS TUF B450M-Plus mATX motherboard doesn’t have a built in graphics card. I had only tried with the driver free. Trying just now with the driver non-free, I get the same result.

#4

Same thing happened here


In your case, you will have to create a file in /etc/modprobe.d called for instance blacklist-nouveau.conf with the following lines

blacklist nouveau
options nouveau modeset=0

Probably adding the nouveau-modeset=0 (something like that) or nouveau_modeset=0 as kernel boot parameter will help. In some instances, even while booting with nonfree option it might help to also add nomodeset together with the above.

1 Like
#5

So the boot parameters with the liveCD when nonfree is enabled for the driver also has nouveau.modeset=0. Adding module_blacklist=nouveau,sp5100_tcp to the linux line still gives the same result.

#6

Can you switch TTY?

#7

Yes. It seems like your above suggestion wouldn’t be doing anything different compared to modifying the boot kernel parameters via the above screen (pressing e on the boot option in the boot menu):

#8

Ok then, if you can switch TTY, from that log in using manjaro for user and password and type startx then Enter
If the session starts, then do the install, if ends in an error, post that error. You can also try to boot in level mode 3, by adding 3 as boot parameter and try startx that way.

1 Like
#9

Running startx with 3 as a boot param plus the previous boot kernel params for module_blacklist and driver as nonfree didn’t work:

xauth: .XAuthority doesn't exist
# snip
(EE) No screens found
Please consult the x.org Foundation for support at Https://wiki.x.org
# snip
xinit: server error
#10

Is this one of the latest ISO or an older one?

#11

It’s an older one, shall I get the latest?

#12

Worth trying, even the Manjarowish one that has the 5 kernel could be a possibility …

#13

I downloaded the ISO and tried to use Xfburn to write it to the disc, with the lowest write speed of 3x, but got the error: “Failure: SCSI error on write(1914256,16): [3 0C 00] Medium error. Write error.” I’ll try again as it’s a RW disc with a RW disc.

#14

Okay so I just tried again with a DVD-R that completed the write of Manjarowish. Didn’t work with free, same thing. Tried again with non-free, and nouveau and sp5100_tco blacklisted. Same thing.
Went to the TTY, logged in,
ran startx, got the same error as previously.
Trying again with 3 as a boot Param:

#15

Whoops, I forgot to swap the CDs over! I was able to boot to the installer.

#16

post installation - the trick to get sp5100_tco working properly is to have it initialised first. you can do that by adding it into mkinitcpio.conf as follows.

  1. open terminal.
  2. issue the command sudo nano /etc/mkinitcpio.conf
  3. find the line that starts MODULES=
  4. alter it so it reads MODULES=(sp5100_tco)

if you want any additional modules loaded earlier put a space between them, they can all be enclosed in the single quote marks already entered, do not add more. e.g. (sp5100_tco amdpgu)

  1. write out the change using CTRL+O
  2. exit using CTRL+X

6 b. edit /etc/default/grub.conf and remove any blacklist reference to sp5100_tco.

  1. regenerate the linux image with sudo mkinitcpio -P
  2. if you altered grub you also need to sudo update-grub