Can't boot Manjaro Linux


Hi all,
Sorry for the vague title, but I’m in a bit of a mess. I’ve recently flashed Manjaro 17.0.4 to a usb and installed it on my computer. During installation, everything went smoothly. I opted to use the non-free graphics drivers in the installation, and upon completion of the installation and rebooting the system seemed to be running fine. Now, here is where my problem is. My system runs completely fine except for when I reboot the second time, where I placed into the text based console of Manjaro with no error messages. (The one that asks for your username and password and to login.) Sometimes, about 50/50, I get an error about some usb problem, but it’s always too fast for me to read. I think the error code is either -19, or -35, or something along those lines. I’ve tried quite a few other solutions, including logging in and doing “startx” and also looking at console to see what the problem might be. I can post photos of anything you guys might need to help me with. Thanks.


Also. just some other things I’ve tried:

Typing “startx” attempts to start gnome, but fails with the code “couldn’t connect to display server”. Same with “xinit”.

Typing “gnome-session” only gives me the output “Terminated”.

All packages are up to date and none were in the process of updating upon my restart. I’ve retried this like a dozen times now, reinstalling, and everytime on the second reboot it just kicks me to the console.