Can't boot Manjaro it stucks at started TLP system


Hello everyone ,
Today i tried to install manjaro for the first time but i couldn’t manage to do it.
First i tried with 17.02 stable kde but when i tried to get into LiveMedia
it stuck at this screen (Started TLP system starup/shutdown.)

Then i made a quick search and found out that someone advised manjaro-architect.

With architect iso, i was able to install manjaro by following this tutorial Installation with Manjaro-Architect ISO it helped a lot thanks. i installed systemd as init, proprietary video-drivers and KDE as desktop environment. it was all good and nice until i restarted my computer and tried to boot manjaro. It stuck at the same screen!! I tried to boot with nomodeset as kernel parameter and it didn’t work neither.

What should i do?

Sorry for my bad English btw.

Manjaro not booting after todays December 2017 update
Manjaro TLP startup/shutdown, stuck in boot (possible partial update problem)
A start job is running for LiveMedia MHWD Script loop

Does you PC have UEFI, did you boot UEFI or Legacy, have you tried changing free drivers and nonfree drivers from boot menu of the install media?


yeah i booted uefi and i have tried both free and non-free drives for kde install media and nothing changed


Do you have an Nvidia GPU or AMD ? Does your PC/Laptop have an integrated Intel GPU ? Can you disable it from BIOS prior the installation then fix accordingly if is a laptop ? On desktop is better to keep it disabled.


Yes i have both intel and nvidia gpu,mwhd (i guess) installed bumblebee and hybrit packages during the installation. I dont think i have an option for disableing intel gpu at bios? (it is a laptop)


It’s your graphic card issue (bumblebee and hybrid).

Boot up to prompt [1] and correct your graphic card drivers from prompt.
Unfortunately, I cannot help with your graphic card issue (search this forum) or others can help up here.

Good luck.

[1] - to boot to prompt -
At grub menu, press 'e’
Arrow down to linux line
Arrow right past ‘quiet’ and 'splash’
Backspace to remove ‘quiet’ and ‘splash’ taking care not to remove 'rw’
Add ‘3’ (without apostrophes meaning just 3)
Press F10 or ‘ctl’ + ‘x’ to boot
login with password to prompt.

At prompt,

[KDE64]-Desktop Boots To Black Screen With Drop Down Terminal?

thank you i managed boot prompt but what to do then ?

i tried to pacman -Rs nvidia
it said target package not found.

i tried pacman -Rs bumblebee

it said, can’t stop dependencies (primus)

i am still looking for help


Okay, as I said, I cannot help much with graphic and suggest you search the forum.
If you have no further assistance from someone else or you cannot find a satisfactory answer.
My suggestion is that at prompt,

mhwd -l
mhwd -li

Remove all what’s listed in ‘mhwd -li’ by

sudo mhwd -r <what's installed in mhwd -li>
sudo mhwd -a pci  free  0300

If someone else comes along, or you find a better search, follow that.

ps: It confirms it’s a graphic issue and not an installation problem.

[edit] - with new installation, always do first this when you reached prompt
sudo pacman-mirrors -g
sudo pacman -Syyu


Hey, i have one good and one bad news.
When i tried to run “sudo mhwd -r <what’s installed in mhwd -li>” command, screen has frozen :frowning:
But when i was installing manjaro i installed 2 kernels 4.13 and 4.9 manjaro lts.
I tried to boot with lts kernel annnd i am in desktop right now (yyeey) kde is beautiful btw.
But now the question is how can i uninstall 4.13 kernel and make 4.9 lts kernel my default kernel.


search for manjaro settings manager, open it up and there should be kernels. from there you remove whatever you need.


sudo mhwd-kernel -r linux413


thanks a lot man.
I have o last thing to ask you (sorry i bother you a lot)
i am dual booting antergos with manjaro now. Since i have grub bootloader installed i didn’t install another bootloader during the manjaro installation. In antergos i run this command :sudo grub-mkconfig -o /boot/grub/grub.cfg
and it detected manjaro.
Is it just okey or should i do anything else?


Not okay. The trouble is Manjaro needs Manjaro bootloader to boot up. Other OS’s bootloader will not boot up manjaro without modifications to their bootloader configurations. And the easiest thing (not the ideal) is to let Manjaro bootloader boot up everything else.

I’ve tested Antergos (no longer have it) and Manajro will take some time to detect Antergos in the os-prober. You need to make an entry in Antergos /etc/lsb-release so that Manjaor will detect Antergos faster.
Also Antergos does not have intel-ucode installed (you can install it manually, I’ve done it in my test and works) because i think it blindly follows Arch and cannot handle intel-ucode well.

So just make Manjaor bootloader as default and remember to set something in Antergos /etc/lsb-release.
And you’re welcome.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.