Can't boot Manjaro 20.10 XFCE from SDcard on Pinebook Pro

downloaded Manjaro-ARM-xfce-pbpro-20.10.img.xz decompressed, and wrote to micro SD via etcher. Insert sdcard to PBP (currently running Manjaro Plasma) and power on. After some time error appears
EXT4-fs error (device mmcblk1p2): ext4_journal_check_start:83: Detected aborted journal
EXT4-fs (device mmcblk1p2): Remounting filesystem read-only

I booted Plasma , inserted card and tried to expand that device to full remainder of 64G card, which failed.

I’ve repeated the write to SD card several times (trying Pine64 Installer & different SD Card) and get same result.

Sounds like you have a corruption in the original ISO or on your card.

  • Did you check the SHA1 of your download? It should be b8592b047640b87ee03f957a8afa120e660f5be7 for Manjaro-ARM-xfce-pbpro-20.10.img.xz

  • Did you check your SD card for errors on another machine?

    smartctl --all /dev/XdY

    where X and Y are the designated disk letters of your card on that machine (Generally /dev/sdd or /dev/sde)


P.S. I’ve also reclassified your question into the ARM category so some people better than me can have a look too.

You could try this, which works for me each time.

  1. Install manjaro-arm-flasher from the Manjaro ARM repo.
  2. Plug in your SD card.
  3. Run “Manjaro ARM Flasher” and select pbpro, xfce and 20.10 respectively.
  4. Make sure that the "Target Block Device field is set to your SD card.
  5. Press Start. This will download the image directly from our CDN and ask if you want to flash it when it’s done. Say Yes to this.
  6. Wait until it’s done.
  7. Voila. You know have an SD card with Manjaro XFCE for pinebook pro.

I actually just did this, with this image, yesterday for testing other stuff.

1 Like

I guess this is another ‘urban legend’
ANY compressed file, xz, gz, zip, lha is INHERENTLY self checking,
ever tried to repair a ‘broken’ zip? Damn hard isn’t it?
So, if it extracts, it was downloaded OK, also there is ALWAYS a “test” function
etcher will “eat” compressed files just fine, you may wish to inspect before “burning”
And to OP, whenever resize2fs errors out, it always explicitly states to run a fsck, so…
What is not so commonly known, sometimes you have to do it twice (fsck)

I missed:

If you use dd: garbage in, garbage out… (and a truncated ISO file gives all kind of weird install errors at the very end of the install, so a quick SHA1 rules out that possibility…)


Err, no xzcat or xz --decompress or xz -t will error out
ISO is not a compressed file, md5sum is a good idea for them, yes
And that’s why it is good idea to zip an ISO, not often done


The error with the journal could be solved by using another SD card.

Have also one SD card here which produces this error on booting Manjaro. No failures in smartctl. Maybe an incompability between this SD card and the PineBookPro

1 Like
  • Open the broken SD card in your distro’s partition editor,
  • Create a new msdos partition table
  • format the card using FAT32

Furthermore, I’ve marked the below answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.