Can't boot Linux59-rt by default

I’m a bit lost here, I just want it to boot linux59-rt by default but I have to manually select it in grub every time. Both linux59 and linux59-rt are installed currently, not sure if I can remove linux59 or if that would break anything but it won’t let me remove it anyway.

How can I make it default?
In /etc/default/grub I have set



But it still doesn’t boot by default.

Any help is appreciated,
Thank you

Try with:
then update grub with
sudo update-grub
from terminal, reboot after that and test again.

Unfortunately this didn’t work, I also now get an error when booting:

Error: sparse file not allowed.

Press any key to continue…

I should add that it still boots, I just have to press enter


see here

Okay the error is gone, thanks.

The linux59-rt kernel still doesn’t load by default though, maybe it’s because it’s older than the current linux59 I have installed? I’m not sure though

It should boot the last kernel you used, by default. That is what happens on my end and on all installs i tested.

Then I have no idea, because I have reinstalled 3 times in the past 2 days and I get the same problem. I install the OS, update, reboot, open the manjaro settings manager, go to kernel and install Linux 5.9.1_rt19-1, reboot, select the kernel, works fine, then i reboot without selecting the kernel and it boots the normal Linux 5.9.16-1 again. Maybe there’s something wrong with how I’m doing it?

I’ve solved it

Installed Linux5.10 then removed 59 and 59-rt, install only the 59-rt, rebooted into 59-rt, then removed 5.10. Rebooted and Linux59-rt is now the only kernel and boots by default.

GRUB options GRUB_DEFAULT=saved and GRUB_SAVEDEFAULT=true do work to save user selection from GRUB
But after sudo update-grub the default is reset to the first menuentry,
So user will need to set preferred boot option again after GRUB is updated

For using multiple kernels, I suggest adding GRUB_DISABLE_SUBMENU=true option so the saved boot option is not hidden in Advanced Options

1 Like

I do not have that entry, multiple kernels here and multiple installs. Indeed the update of grub will reset the default entry, but that only happens when installing new kernel or doing an update, right?

Option GRUB_DISABLE_SUBMENU is not in Manjaro /etc/default/grub
but it is in the GNU GRUB Documentation

User would have to add the option

echo 'GRUB_DISABLE_SUBMENU=true' | sudo tee --append /etc/default/grub

and update GRUB again

My GRUB boot menu looks similar to this (but with a green highlight for saved boot) :

Manjaro Linux (Kernel: 5.10.7-3-MANJARO x64)
Manjaro Linux (Kernel: 5.10.7-3-MANJARO x64 - fallback initramfs)
Manjaro Linux (Kernel: 5.9.1-rt19-1-MANJARO x64)
Manjaro Linux (Kernel: 5.9.1-rt19-1-MANJARO x64 - fallback initramfs)
Manjaro Linux (Kernel: 5.4.89-1-MANJARO x64)
Manjaro Linux (Kernel: 5.4.89-1-MANJARO x64 - fallback initramfs)

Not so pretty or tidy, but a lot more functional IMO

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.