Can't Boot Linux - AMD R9 380

amdgpu

#1

Hi, I have a problem with booting a Manjaro. It’s all because of GPU driver I think. I have MSI R9 380. I try Mint Cinnamon and Manjaro Cinnamon and the same problem. When I launch boot system, I get some logs and after it’s only black screen, my monitor has no signal. I tried free and non-free drivers in manjaro GRUB menu. When I type nomodeset in boot options before booting it’s working but without accelaration and sometimes I haven’t good displat resolution.

Please help me, any solutions to fix this problem?


#2

Can you boot with nomodeset then open a terminal and and run inxi -Fxz. When you paste the output make sure you put ``` before and after the text, that will force it to format correctly (and be readable). Then we can look at your hardware to see if there is a known solution.


#3
System:
  Host: manjaro-cinnamon Kernel: 4.19.4-1-MANJARO x86_64 bits: 64 
  compiler: gcc v: 8.2.1 Desktop: Cinnamon 4.0.1 Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: ASRock model: B85 Killer serial: <filter> 
  BIOS: American Megatrends v: P1.70 date: 09/17/2014 
CPU:
  Topology: Quad Core model: Intel Core i5-4690K bits: 64 type: MCP 
  arch: Haswell rev: 3 L2 cache: 6144 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28005 
  Speed: 4201 MHz min/max: 800/4200 MHz Core speeds (MHz): 1: 4201 2: 4203 
  3: 4200 4: 4199 
Graphics:
  Device-1: AMD Tonga PRO [Radeon R9 285/380] vendor: Micro-Star MSI 
  driver: N/A bus ID: 01:00.0 
  Display: x11 server: X.Org 1.20.3 driver: vesa tty: N/A 
  OpenGL: renderer: llvmpipe (LLVM 7.0 256 bits) v: 3.3 Mesa 18.2.5 
  direct render: Yes 
Audio:
  Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: ASRock 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Device-2: AMD Tonga HDMI Audio [Radeon R9 285/380] vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  Device-3: HP type: USB driver: hid-generic,snd-usb-audio,usbhid,uvcvideo 
  bus ID: 3-4:2 
  Sound Server: ALSA v: k4.19.4-1-MANJARO 
Network:
  Device-1: Qualcomm Atheros Killer E220x Gigabit Ethernet vendor: ASRock 
  driver: alx v: kernel port: d000 bus ID: 05:00.0 
  IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 706.10 GiB used: 4.4 MiB (0.0%) 
  ID-1: /dev/sda vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB 
  ID-2: /dev/sdb vendor: Crucial model: CT250BX100SSD1 size: 232.89 GiB 
  ID-3: /dev/sdc type: USB vendor: SanDisk model: Cruzer Blade 
  size: 7.45 GiB 
Partition:
  ID-1: / size: 5.78 GiB used: 4.4 MiB (0.1%) fs: overlay source: ERR-102 
Sensors:
  System Temperatures: cpu: 40.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 187 Uptime: 2m Memory: 7.71 GiB used: 865.2 MiB (11.0%) 
  Init: systemd Compilers: gcc: 8.2.1 Shell: bash v: 4.4.23 inxi: 3.0.27 

#4

Usually with this kind of issue it’s the video card. So looking for other posts what I would try is:

If that works, then once you install you can do:

to make it permanent.


#5

Wow, it’s working now. Thank you. I can install now Manjaro. What does this command do? I mean amdgpu.dc=0

edit

I install Manjaro succesfuly but boot time is too long. :confused: It’s about 50 sec when Win 10 launch in 5 sec.


#6

https://www.phoronix.com/scan.php?page=news_item&px=AMDGPU-DC-Accepted

DC is the “new display code stack” for the AMD GPU…setting it to 0 disables it…I’m guessing it’s needed for the newer AMD GPUs but it has issues with the older ones…

As for boot speed, I suspect you are comparing apples and oranges…Linux is booting up… i.e. starting from a clean state and loading everything it needs. Windows probably “hibernates” itself which means it writes it’s current state to disk, then reloads that state when it starts back up.

You might be able to enable hibernate for linux: https://wiki.archlinux.org/index.php/Power_management/Suspend_and_hibernate I’ve never done it…and the are plenty of threads about issues coming out of hibernate, but you might be able to get it to work.

Other than that:

systemd-analyze blame
systemd-analyze critical-chain

are two commands that can be used to look at what services are taking the longest to start. Then you would need to investigate how to speed them up.


#7

Working good now. This delay was twice, at the first starts. Thank’s for help.
Thread can be closed.


#8

Mark it solved please.