Can't boot into Manjaro after switching to UEFI

EFI requires GPT partition schema.

Legacy or BIOS can work with both but in case of GPT special attention is required.

I guess you are using MBR - which explicitly disables EFI.

And just to remind everyone - Windows is off-topic.

did the reinstall of grub report errors?

Nope, no errors there

No the partition table is GPT

there is this:

ERROR: mkdir /var/lock/dmraid

but how to fix it, or if it means anything i dont know …
so run just in case these commnad:
mkinitcpio -P

I ran
mkinitcpio -P

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck --debug

in that order and the error disappeared, but I still can’t see grub in the BIOS menu.

this looks lie souped up system, were you using reFind as well

did experiment with raid setup?

Your devices perhaps got raid partition type guid and therefore the system thinks it is raid?

Why do you think this is significant?

I don’t know what raid is, but everything I did is described in the first post.

That is the way one selects which bootloader to use, no ?
So if I can select grub, I should be able to boot into grub.

Yes, I installed refind since grub didn’t work and it worked for OP in this post

the mkinit command should be run after you reinstalled grub not before…
so if you start your pc into what os does it boot?
also you said that you installed windows and windows worked normally, so did you disabled fastboot in windows?

When I boot now it boots into refind, there I can currently select Windows and the live-usb.
Fastboot is disabled in the BIOS.

did you run again the mkinit command after you reinstalled it the second time?
post also:
cat /etc/fstab/

I think this is your issue - the partition is flagged as legacy_boot - if you load up cgdisk for /dev/sdc you will find the partition type guid to be ef02 - where it should be ef00

Ah, I see. How exactly do I remove this flag ?

so I did sudo cgdisk /dev/sdc and selected the ESP partition, it says Current type is ef00.

Delete the partition and recreate it.

The rerun the commands to install grub efi as described earlier.

Yes, I did, but no change.


/dev/loop1: TYPE="squashfs"
/dev/sdd1: BLOCK_SIZE="512" UUID="0E8A16C30E8A16C3" TYPE="ntfs" PARTUUID="0e8a03b4-01"
/dev/sdb2: UUID="e4819263-1437-47cb-8afa-8e9230eb7a8d" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="ba2cac38-02"
/dev/sdb3: UUID="6697a587-6eda-4f18-88a9-1ba83fc20b33" TYPE="swap" PARTUUID="ba2cac38-03"
/dev/sdb1: LABEL="Hauptplatte" BLOCK_SIZE="512" UUID="01D3C542C44B29D0" TYPE="ntfs" PARTUUID="ba2cac38-01"
/dev/loop2: TYPE="squashfs"
/dev/loop0: TYPE="squashfs"
/dev/mapper/ventoy: BLOCK_SIZE="2048" UUID="2022-07-21-09-20-14-00" LABEL="MANJARO_KDE_2135" TYPE="iso9660" PTTYPE="dos"
/dev/sde2: SEC_TYPE="msdos" LABEL_FATBOOT="VTOYEFI" LABEL="VTOYEFI" UUID="66F6-D57E" BLOCK_SIZE="512" TYPE="vfat" PARTUUID="b7bffb6a-02"
/dev/sde1: LABEL="Ventoy" UUID="F508-B40B" BLOCK_SIZE="512" TYPE="exfat" PTTYPE="dos" PARTUUID="b7bffb6a-01"
/dev/sdc2: UUID="911149de-2563-4198-89df-8d3832fd2b05" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="1e53093d-1d33-a64b-837a-c72603987844"
/dev/sdc3: UUID="63b20c95-fc92-475f-b8b6-18fa6880d5c8" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="08f1477f-c672-0246-b5b5-d6cbcd45c36d"
/dev/sdc1: UUID="3A10-AD17" BLOCK_SIZE="512" TYPE="vfat" PARTUUID="3350d68a-a33f-3e4b-9eb9-4d75647015d7"
/dev/sda4: BLOCK_SIZE="512" UUID="721437E81437AE4B" TYPE="ntfs" PARTUUID="20f5f276-d59d-4910-906d-fad4d7c5aabe"
/dev/sda3: BLOCK_SIZE="512" UUID="18D45014D44FF314" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="fc0e68ba-83fe-489c-8b07-c56d9ed0b20c"
/dev/sda1: UUID="4C3C-6793" BLOCK_SIZE="512" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="369bdc03-e19a-4890-8630-e7a6a68e696e"
/dev/loop3: TYPE="squashfs"
/dev/sda2: PARTLABEL="Microsoft reserved partition" PARTUUID="43879069-e29b-4733-b2e0-05e9fa8844c5"

cat /etc/fstab

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=6697a587-6eda-4f18-88a9-1ba83fc20b33 swap           swap    defaults,noatime 0 2
UUID=911149de-2563-4198-89df-8d3832fd2b05 /home          ext4    defaults,noatime 0 2
UUID=63b20c95-fc92-475f-b8b6-18fa6880d5c8 /              ext4    defaults,noatime 0 1
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0
UUID=3350D68A-A33F-3E4B-9EB9-4D75647015D7 /boot/efi      vfat    defaults,noatime 0 2

The reference in fstab should be using the UUID not PARTUUID

I think you have tried so many things you are running in circles trying to fix the fix you applied trying to fix …

Your best bet is to zap the sdc device - then start over - because you are having weird partitions flags - your system thinks it’s a raid device and want to use mdraid

This command removes all traces of signatures and backup partition blocks and what not.

sudo sgdisk --zap-all /dev/sdc

This command will fill the first gigabyte of the device with null

sudo dd if=/dev/null of=/dev/sdc bs=10M count=1000 status=progress

Then you can launch the installer and get a clean install to your sdc device

1 Like

Omg, this real did the trick. Thank you @all for your help !

Ah yes, that sounds like something I would do :sweat_smile:

I will do this when I have some spare time, since if I understand correctly I need to reinstall everything again. Right now I need the system back.
Still thank you for your help :blush:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.