Can't boot after software update

After a software update which completed successfully I was asked to reboot. I am now unable to boot and get the following message:

Kernel panic – not syncing: VFS: Unable to mount root fs on unknown-block(0.0)

I have booted with a live DVD and used manjaro-chroot to access the native system. I then used mkinitcpio -P as suggested in other posts, This gave me

===>ERROR: specified kernel image does not exist: ‘/boot/vmlinuxz-5.19-x86_64’

===>WARNING: Preset file ‘/etc/mkinitcpio.d/linux61.preset’ is empty or does not contain presets

===>Using configuration file: ‘/etc/mkinitcpio.conf’ → -k /boot/vmlinuxz-6.2-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-6.2-x86_64.img –mcrocode /boot/amd-ucode.img

===>ERROR: ‘/lib/modules/6.2.16-2-MANJARO’ is not a valid kernel module directory

Guidance as to what I should do would be much appreciated.

That kernel has already been EOL for ages.

And that kernel has also already been EOL for a while.

The above tells me that you have not been keeping your system up to date, and/or that you’ve created a mess out of it, but given that you’re not giving us any details, there’s nothing more I can say, other than the quick & dirty advice of reinstalling. :man_shrugging:

Manjaro is a rolling-release distribution, which means that it must be kept up to date, and that it also requires maintenance — such as merging .pacnew files. As such, you should also read the first two posts of every Stable Updates announcement thread, because they contain important information.

Kernels v5.19 and v6.2 are no longer supported

I suggest check installed kernels

sudo mhwd-kernel -li

and remove any that are not listed in latest stable update announcement, or marked End Of Life

sudo mhwd-kernel -r linux519

Manjaro Kernels - Manjaro

1 Like


If its possible do it again, and uninstall both of those kernels, and instal 6.1 LTS, than reboot and see if it works.

@Aragorn, @nikgnomic this should be possible ??..

1 Like

If the missing kernel is the only problem, then yes. But I suspect there’s more going on than that. :thinking:

Well… according to the OP initial post it seems so.
Anyhow its good to uninstall EOL kernels and go with LTS…

1 Like

What more details would you like? My system is updated regularly , if nor daily, at least weekly. I upgraded to 6.2 within the last week and that was from 6.x, not 5.x. I am as puzzled as you as to why it is referring to 5.19 and I am also puzzled why I was offered 6.2 when I now see that that is not a supported kernel.

What commends can I run that will provide helpful information?

Your database was probably not up to date. Run this in the chroot environment… :arrow_down:

sudo pacman-mirrors -f && sudo pacman -Fy && sudo pacman -Syyu

inxi -Fza would be a good start. :wink:

Thank you. I will do that as soon as I have figured out how to get the result of the machine. Meanwhile, this is what I have in /boot and /lib/modules



Please forgive my ignorance, but how do I get network access in the chroot environment? I do have network access in the live cd booted environment that I am chrooting from but the pacman command is failing because of no network.

If you have network access in the live environment, then you should also have it in the chroot environment.

Something’s not right there. :frowning_man:

Try going over the steps in this tutorial below… :arrow_down:

Hi @barraclm, can you at least boot with kernel 5.15 as it seems you have it intact, meaning you have


When you reboot keep pressing ESC button ( I think its that button :slight_smile: ) to enter gurb menu and select the kernel 5.15

If you are successful please post


How are you chrooting? Maybe the resolv.conf is not mounted or overwritten which it should be.

Or are the mirrors out of date?

1 Like

Thank you so much. I was able to edit the grub configuration so that the menu appeared and then was able to select 5.15 and boot just fine. I have manually removed all the 6.2 files and now have 6.5, 6.4, 6.1 and 5.15 installed with 6.4 booting just fine. I am still puzzled as to why I was offered 6.2 to install, and why there were some other old kernel related files still on the system. However, I am eternally grateful to the support offered in this forum and the fact that I am up and running again.

Michael Barraclough


In my humble opinion…
1st the system was looking to boot with linux 5.19 for some reason… :man_shrugging: and it couldn’t find it so…
2nd It tried to look for WARNING: Preset file ‘/etc/mkinitcpio.d/linux61.preset’, but that’s missing, meaning no initramfs-6.1-x86_64-fallback.img, initramfs-6.1-x86_64.img, so…
3rd It tried to boot with kernel 6.2 but it was missing ===>ERROR: ‘/lib/modules/6.2.16-2-MANJARO’ is not a valid kernel module directory, because the kernel is not in the repos anymore, hence on upadate it couldn’t create the folder in the error above…

You mast have installed the k. 6.2 long before it was EOL, but as to why the system was looking for k. 5.19 I dont know…

Another thing, please stay on one LTS and one current kernel.
Why do you need so much kernels anyway ??

I believe kernel 6.4 will go EOL soon, so you might run into the same trouble again… :slight_smile:

Cheers… :beer:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.