Can't adjust screen brightness

nvidia

#1

Hello, Manjaro community!

I am freshly arrivied newbie and have question regarding brightness of the screen.
I have HP Zbook G2. Optimus technology turned off and currently Nvidia discrete gfx is active.
I can’t change screen brightness. Fn keys not working.
Handle display brightness keys setting is not available, i don’t see switch that turns on/off this setting, but text is visible.
Tried to change kernels, no effect.
Also tried to add
Option “RegistryDwords” “EnableBrightnessControl=1” to 90-mhwd.conf
No luck again…

Any suggestions?


NVIDIA problem, cannot adjust brightness
#2

You likely need to set the acpi_backlight kernel option.

Either edit the GRUB boot line, or set GRUB_CMDLINE_LINUX="acpi_backlight=$VALUE" in /etc/default/grub then sudo update-grub.

There are (at least) three $VALUEs to try:

  • acpi_backlight=none
  • acpi_backlight=vendor
  • acpi_backlight=native

It’s hardware-dependent so you’ll need to try them see which works best for you.


Screen Brightness Keys Not Working
#4

Guys thanks for replies, but it seems that it doesn’t work for me or i am doing something wrong.
Here is more detailed information. If you have some spare time please fix me up.

I tried to change grub. I had following setup:

GRUB_CMDLINE_LINUX=“acpi_osi=Linux acpi_backlight=vendor”
Tried none, native. WIth grub update and reboot - no luck

Currently i am running 4.16.0-1

Contents of my configs, i left only stuff related to display

/etc/X11/xorg.conf.d/90-mhwd.conf

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 390.42  (buildmeister@swio-display-x86-rhel47-07)  Sat Mar  3 04:40:24 PST 2018

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"Section "Extensions"
    Option         "Composite" "Enable"
EndSection

    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
	Option "NoLogo" "1"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Also i have /etc/X11/mhwd.d/nvidia.conf with similar content.

And for the last, here is screenshot of my power settings

I hope that i provided maximum information regarding my case. Looking forward to hearing from you!


#5

That would have been useful up-front. Backlight control is currently broken (for certain hardware with NVIDIA graphics etc. etc.) with 4.16, switch back to 4.15 for now. It’s in the latest Known Issues post:


#6

Thanks for correcting my badly posted message.
I’ll take it into account in future posts.
I will try to follow your guides and fix the problem and report back.


#7

If you can’t get things working then you can try a software controller. I like brightness-controller from the AUR.


#8

Tried to install free-driver version [no nvidia prop]
Problem is the same: brightness is not changing, but at this time popup animation of increasing and decreasing brightness slider appears. “Handle display brightness keys” is turned on.


#9

Have you downgraded your kernel to 4.15 or 4.14 lts


#10

Why? Why didn’t you just try kernel 4.15? I have exactly the same issue with an Optimus laptop running with PRIME - brightness control is broken with 4.16 but works fine with 4.15 (and other) kernels.


#11

Fresh installation comes with 4.14 LTS. Free driver. Not working.

It seems that it is a problem of HP laptop itself.
I’ll continue investigation, report back when find out something.


#12

I tried 4.15 with non-free driver, not working. But it looks like i broke something and decided to try free version.


#13

You should listen to jonathon, you’re just making far more work for yourself.


#14

I am listening, but i am rookie, remember?
So if i am doing something it is not on purpose.
Also i understand that i don’t have some mandatory knowledge to solve such problem in a right manner. Hope you get me.


#15

I get it, but if you’re not sure about what someone is telling you to do, simply ask for clarification. It’s nothing to be embarrassed about, if your unsure.


#16

Seeing as how you already wiped your system, I’d start again with a fresh install. Install with the v4.14 lts kernel and the proprietary (non-free) nvidia drivers. If it is not working after a fresh install try the configuration fixes suggested earlier in the thread. Feel free to use kernel 4.15, but do not upgrade to 4.16. Let us know how it goes. Please correct me if I’ve given him bad advice or forgotten something @jonathon

If you get tired of trying to get things working correctly and aren’t having any luck, try the software I suggested earlier. It will probably not enable your function keys, but it should allow you to adjust your brightness with the GUI app.
brightness-controller-git from the AUR

https://aur.archlinux.org/packages/brightness-controller-git/


#17

Tgb and Jonathon thanks for advises, i will try everything from scratch and report back.


#18

FWIW I am running 4.14.31 kernel on a T420. My nvidia.conf file:


Brightness Fn keys work.


#19

Loontmike, thanks for sharing your config. This will be very helpful!

I put topic on hold for some time, because it looks like, that i broke HP UEFI and can’t boot any more.
I’ll be back in a while.


#20

Finally solved UEFI problem. HP laptops are complete mess regarding boot.

Installed 4.14 with non-free drivers. Brightness not working.
By default config line was empty, like this
GRUB_CMDLINE_LINUX="".

I tried all suggested variations - no luck. After each grub update i made a reboot.
Even tried modified loontmike nvidia.conf. Of course i changed my video card name [rely on information from nvidia settings app]

It looks like HP Zbook G2 is crippled. Will try to use suggested application.


#21

Downloaded Brightness controller, tried to execute and get following error
Failed to execute child process “brightness-controller” (No such file or directory).

Any hints, please?