Can't access tty using Ctrl+Alt+F1,F2,F3 etc

xorg
x11
keyboard

#1

Here is what I have tried:

$ xev
KeyRelease event, serial 43, synthetic NO, window 0x4a00001,
    root 0x1db, subw 0x0, time 23449801, (434,-234), root:(1305,244),
    state 0x1c, keycode 67 (keysym 0x1008fe01, XF86Switch_VT_1), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False
$ systemctl list-units|grep getty
getty@tty1.service                      loaded active running   Getty on tty1                            
getty@tty2.service                      loaded active running   Getty on tty2                            
getty@tty3.service                      loaded active running   Getty on tty3                            
getty@tty4.service                      loaded active running   Getty on tty4                            
getty@tty5.service                      loaded active running   Getty on tty5                            
getty@tty6.service                      loaded active running   Getty on tty6                            
getty@tty7.service                      loaded active running   Getty on tty7                            
system-getty.slice                      loaded active active    system-getty.slice                       
getty.target                            loaded active active    Login Prompts
$ xmodmap -pke
keycode  67 = F1 F1 F1 F1 F1 F1 XF86Switch_VT_1
keycode  68 = F2 F2 F2 F2 F2 F2 XF86Switch_VT_2
keycode  69 = F3 F3 F3 F3 F3 F3 XF86Switch_VT_3
keycode  70 = F4 F4 F4 F4 F4 F4 XF86Switch_VT_4
keycode  71 = F5 F5 F5 F5 F5 F5 XF86Switch_VT_5
keycode  72 = F6 F6 F6 F6 F6 F6 XF86Switch_VT_6
keycode  73 = F7 F7 F7 F7 F7 F7 XF86Switch_VT_7
keycode  74 = F8 F8 F8 F8 F8 F8 XF86Switch_VT_8
keycode  75 = F9 F9 F9 F9 F9 F9 XF86Switch_VT_9
$ setxkbmap -print -verbose 10
Setting verbose level to 10
locale is C
Trying to load rules file ./rules/evdev...
Trying to load rules file /usr/share/X11/xkb/rules/evdev...
Success.
Applied rules from evdev:
rules:      evdev
model:      pc104
layout:     us
variant:    intl-unicode
options:    terminate:ctrl_alt_bksp
Trying to build keymap using the following components:
keycodes:   evdev+aliases(qwerty)
types:      complete
compat:     complete
symbols:    pc+us(intl-unicode)+inet(evdev)+terminate(ctrl_alt_bksp)
geometry:   pc(pc104)
xkb_keymap {
        xkb_keycodes  { include "evdev+aliases(qwerty)" };
        xkb_types     { include "complete"      };
        xkb_compat    { include "complete"      };
        xkb_symbols   { include "pc+us(intl-unicode)+inet(evdev)+terminate(ctrl_alt_bksp)"      };
        xkb_geometry  { include "pc(pc104)"     };
};
cat /etc/X11/xorg.conf.d/00-keyboard.conf
# Written by systemd-localed(8), read by systemd-localed and Xorg. It's
# probably wise not to edit this file manually. Use localectl(1) to
# instruct systemd-localed to update it.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "us"
        Option "XkbModel" "pc104"
        Option "XkbVariant" "alt-intl-unicode"
EndSection

Xorg log at boot

	Information	[     6.294] (**) Eee PC WMI hotkeys: Applying InputClass "evdev keyboard catchall"
	Information	[     6.294] (**) Eee PC WMI hotkeys: Applying InputClass "libinput keyboard catchall"
	Information	[     6.294] (**) Eee PC WMI hotkeys: Applying InputClass "system-keyboard"
	Information	[     6.294] (**) Eee PC WMI hotkeys: Applying InputClass "Keyboard Defaults"
	Information	[     6.294] (II) Using input driver 'libinput' for 'Eee PC WMI hotkeys'
	Information	[     6.294] (**) Eee PC WMI hotkeys: always reports core events
	Information	[     6.294] (**) Option "Device" "/dev/input/event16"
	Information	[     6.294] (**) Option "_source" "server/udev"
	Information	[     6.295] (II) event16 - Eee PC WMI hotkeys: is tagged by udev as: Keyboard
	Information	[     6.295] (II) event16 - Eee PC WMI hotkeys: device is a keyboard
	Information	[     6.296] (II) event16 - Eee PC WMI hotkeys: device removed
	Information	[     6.347] (**) Option "config_info" "udev:/sys/devices/platform/eeepc-wmi/input/input16/event16"
	Information	[     6.347] (II) XINPUT: Adding extended input device "Eee PC WMI hotkeys" (type: KEYBOARD, id 14)
	Information	[     6.347] (**) Option "xkb_model" "pc104"
	Information	[     6.347] (**) Option "xkb_layout" "us"
	Information	[     6.347] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
	Information	[     6.349] (II) event16 - Eee PC WMI hotkeys: is tagged by udev as: Keyboard
	Information	[     6.349] (II) event16 - Eee PC WMI hotkeys: device is a keyboard
	Information	[     6.350] (II) config/udev: Adding input device PC Speaker (/dev/input/event8)
	Information	[     6.350] (II) No input driver specified, ignoring this device.
	Information	[     6.350] (II) This device may have been added with another device file.
	Information	[     6.359] (**) USB Keyboard Consumer Control: Applying InputClass "evdev keyboard catchall"
	Information	[     6.359] (**) USB Keyboard Consumer Control: Applying InputClass "libinput keyboard catchall"
	Information	[     6.359] (**) USB Keyboard Consumer Control: Applying InputClass "system-keyboard"
	Information	[     6.359] (**) USB Keyboard Consumer Control: Applying InputClass "Keyboard Defaults"
	Information	[     6.359] (II) Using input driver 'libinput' for 'USB Keyboard Consumer Control'
	Information	[     6.359] (**) USB Keyboard Consumer Control: always reports core events
	Information	[     6.359] (**) Option "Device" "/dev/input/event4"
	Information	[     6.359] (**) Option "_source" "_driver/libinput"
	Information	[     6.359] (II) libinput: USB Keyboard Consumer Control: is a virtual subdevice
	Information	[     6.359] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb1/1-5/1-5:1.1/0003:0566:3067.0002/input/input4/event4"
	Information	[     6.359] (II) XINPUT: Adding extended input device "USB Keyboard Consumer Control" (type: KEYBOARD, id 15)
	Information	[     6.359] (**) Option "xkb_model" "pc104"
	Information	[     6.359] (**) Option "xkb_layout" "us"
	Information	[     6.359] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"

I also DON’T have “Keyboard Settings > Advanced > Miscellaneous compatibility options > Special keys handled in server” checked.

Also read this post [Virtual consoles not working (Ctrl+Alt+F1-6)] but didn’t help.

Also tried commenting out “Option “XkbVariant” “alt-intl-unicode”” from /etc/X11/xorg.conf.d/00-keyboard.conf file.

Also tried Ctrl+Alt+Fn+[F1-F2-etc]

$ chvt [x] works, I get a prompt. And Ctrl+Alt+F? also works to switch between ttys. But when I start an X session it stops working. I have no other issues with my keyboard, even function and media keys work as expected.

Please help. I have been fighting with this for a while now.

Thank you.
Gastón


#2

ctrl+fn+alt+F1

theres an option in bios (for me anyway) that changes if the function(fn) is on or off by default


#3

Also tried that. No luck either. Fn key work well a far as I can tell. Can control volume, brightness and other media keys a expected.


#4

is this new behavior or did this never work properly?


#5

It never worked since I got this system as far as I remember.


#6

have you tried using right ctrl + right alt F2-3-4-5-6 (i dont see why it would matter, possible key problems?)


#7

Yes I have tried “all” possible combinations of right and left Ctrls and Alts, and also Meta and Fn. No result. But even I don’t see why that would matter because xev shows me that the key combination is being recognized. Idk.

Also once I get to a tty (via chvt) I can gracefully switch between them using Ctrl+Alt+F1,2,etc as long as I don’t land on a graphical session.


#8

do you happen to have a manjaro live usb/disk you could boot up and see if it behaves the same way?

sorry i couldnt be of more help. maybe someone more experienced than i will know this one. i have no clue why it would stop working only when your on a graphical environment


#9

I could try that later. I will post the outcome when I have it. Thank you anyways for your time. Maybe somebody will know.