Can't access Samba share from windows

Hi,

I've checked other posts regarding samba shares and could not get anything to work.
I'm using Manjaro, I've setup a samba shared folder but I'm unable to access it from Windows or Android.
Samba is installed and running
Any help would be appreciated

My smb.conf folder is

[global]
workgroup = WORKGROUP
dns proxy = no
log file = /var/log/samba/%m.log
max log size = 1000
client min protocol = SMB2
server role = standalone
passdb backend = tdbsam
obey pam restrictions = yes
unix password sync = yes
passwd program = /usr/bin/passwd %u
passwd chat = NewUNIXpassword %n\n ReTypenewUNIXpassword* %n\n passwd:allauthenticationtokensupdatedsuccessfully*
pam password change = yes
map to guest = Bad Password
usershare allow guests = yes
name resolve order = lmhosts bcast host wins
security = user
guest account = nobody
usershare path = /var/lib/samba/usershare
usershare max shares = 100
usershare owner only = yes
force create mode = 0070
force directory mode = 0070
wins support = yes

[share]
path = /mnt/other/share
read only = no
guest ok = yes

Output from "smbclient -L localhost -U%"

Unable to initialize messaging context

Sharename Type Comment


print$ Disk Printer Drivers
share Disk Shareable content
IPC$ IPC IPC Service (Samba 4.10.10)
SMB1 disabled -- no workgroup available

Just a quick comment on the last line in that output:

SMB1 disabled -- no workgroup available

Just for the test, try if it works if you use a SMB1 protocol (like NT1)?

Also an unrelated comment, I see you use map to guest = Bad Password. Just in case you are not aware, that setting means if you mistype your password you will get logged in, but as the guest user - and it can be a bit confusing, as you might not notice.

Are you running a firewall? Can you access the smb share from the local machine?

If I change "client min protocol" to SMB1, the service fails to start. Gives a "failed (Result: exit-code)" error.
I understand the issue with guest, but at this point I'm just trying to access it.

Have you tried to create a samba user? assign a passwd and use that user:passwd to access the service?

Also a package exist - installing a smb.conf and starting the necessary services.

@dalto, I'm not running any firewall.
I have created a password for a samba user and it still fails.
And I have installed the package you mention @linux-aarhus

Some more info

Status of smb.service

~ >> sudo systemctl status smb.service
● smb.service - Samba SMB Daemon
Loaded: loaded (/usr/lib/systemd/system/smb.service; enabled; vendor preset: disabled)
Active: active (running) since Tue 2020-01-14 20:17:35 WET; 6min ago
Docs: man:smbd(8)
man:samba(7)
man:smb.conf(5)
Main PID: 1012 (smbd)
Status: "smbd: ready to serve connections..."
Tasks: 4 (limit: 4915)
Memory: 27.0M
CGroup: /system.slice/smb.service
├─1012 /usr/bin/smbd --foreground --no-process-group
├─1044 /usr/bin/smbd --foreground --no-process-group
├─1046 /usr/bin/smbd --foreground --no-process-group
└─1050 /usr/bin/smbd --foreground --no-process-group

ene 14 20:17:35 nfmsbox systemd[1]: Starting Samba SMB Daemon...
ene 14 20:17:35 nfmsbox systemd[1]: Started Samba SMB Daemon.
ene 14 20:17:35 nfmsbox smbd[1012]: [2020/01/14 20:17:35.831385, 0] ../../lib/util/become_daemon.c:135(daemon_ready)
ene 14 20:17:35 nfmsbox smbd[1012]: daemon_ready: daemon 'smbd' finished starting up and ready to serve connections
ene 14 20:23:28 nfmsbox smbd[3022]: pam_unix(samba:session): session closed for user nobody

Uhm... sorry if I suggest the obvious, but what you have done seems correct, so what's wrong is probably hiding behind the obvious :crazy_face:

  • have you also made a Samba user for "nobody"?
  • are you also running nmb.service?
  • server role = standalone is correct according to the Samba documentation, but I have "standalone server", and with me it works, so it may be worth a shot?

Good luck!

Thanks for your suggestion @Ferdinand.
I have done all that it still fails.
Maybe I'm getting something wrong but the fact is that I have a raspberry running KODI and I can access the shared folders with the default settings of the program I use on Android.
However on my computer it can't connect. It's very frustrating.

Do you have
valid users = @securedgroup
on smb.conf ?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by