Can't access new nvme hard drive

I just bought a new Crucial 2tb NVME stick for my second nvme slot on my ASUS ROG mother board.
It is my 4th hd. I have 1 hd with windows on it but I haven’t loaded into windows in over 2 years.
I formated the stick ext4 and it is mounted. It is in /run/media/usul75 but it will not let me put anything on it. I’ve installed ssd’s and never had this issue. I have been using Manjaro for 4 years but I am by no means any kind of power user. I don’t use command line very often.

By default only root, so ID 0, has permissions after formatting with ext4. You need to claim permissions. When you use gnome-disks for example you can click on the partition and in the menu click on “Take ownership” or just use the terminal:

sudo chown -r $USER:$USER  /run/media/usul75/<mountpoint>

:notebook: Note: Replace <mountpoint>

In my /etc/fstab I changed the entry for another internal hard disk:

UUID=4c618674-47d9-48d5-8bec-7016368b14ae /media/archiv ext4 defaults,noatime,nosuid,x-gvfs-hide 0 2

(EXAMPLE only!)
The point is the parameter: nosuid
Then the permissions of all users are ignored.
megavolt, please verify this :innocent:

Wrong. SUID flag (Set User ID) must be set if you run a program as user, which needs root permissions. If you disable that on an external drive, then programs which are located there are not able to run with root permissions themselves, this is a security measurement.

Here you can get a list:

find /usr/bin -type f -perm /u=s,g=s

If you disable that on you root partition, then say good bye to su or sudo or pkexec etc.

But that is totally out of topic now.

Sorry to correct you here but…
The SUID bit is to run programs as the user the file is set to as owner, this can be any user account.
It has nothing todo with being able to run it with root permissions.
See it as a shortcut for changing to the user the file-permissions show as owner, and then execute that file as that user.

Disabling SUID bit on a mount means that bit is ignored, and thus this feature is disabled on that mount.

Yes there is a security measure to prevent SUID to root, and SUID on shell scripts, but that is not directly related to the functionality.

Try this after mounting that device:
(To give access to anyone)

sudo chmod -R a+rwX /run/media/usul75

or if you only want it accessible to your user account do as @megavolt showed in Reply #2

1 Like

Sorry, but in which way did I say something different? You run for example sudo for example as user, and sudo itself can privilege another app run as root. There you need the SUID:

From: Linux 101: What is the SUID permission? | TechRepublic

And now? Still see no difference in my wording. :man_shrugging:

You implied they were unable to be run as root using sudo etc, or at least that’s how i understood your wording…
Example try disabling SUID on the mount and then run a program on it using sudo, it will still work :wink:

Anyhow we are indeed derailing the topic, so lets keep it to the OP :wink:

No. But one reads what one thinks it reads and not read what it meant to say. :man_shrugging:

One writes what it thinks it writes but that can be different as what others read what is written…
Intentions are not the same as the meaning of wordings in a sentence…

Anyhow you meant the same as i do, so lets carry on with the OP…

Correct, I for my part use the additional internal drive for timeshift and as an Archiv for /home/
not to run programs from.
Discussion (german site):

What do I replace with?
Is it the name that I gave the drive? do I need the brackets?
If I use the name of the drive with <> included it returns
zsh: parse error near `\n’

If I don’t include the <> it returns
chown: invalid option – ‘r’

I named the drive games and that is what I put in place of mountpoint.
then I tried /dev/nvme1n1 and /dev/nvme1n1p2
none work

I am not very command line literate sorry.
I did assume I was supposed to change $USER to $usul75

edit: comment not showing mountpoint inside the<>

Ok, a bit of education…

When you mount an external drive with your file manager, then it usually mounts to: /run/media/username/partitionname It literally creates the whole directory and mounts it just there.

:notebook: /run is a tmpfs. That means it only exists in the RAM.

:notebook: <mountpoint> was meant to be a placeholder. So without <>.

ok sorry, that was a typo. It have to be -R or just --recursive.

In /dev are actually the real devices. It needs to be mounted into a folder.

So please mount it in Dolphin, I guess? There you should see the full path in the addressbar. Just copy in paste it there instead.

sudo chown --recursive --verbose $USER:$USER /path/to/mountpoint

Please don’t just copy and paste it. The last parameter, so the path must be correct. $USER is a variable which contains your username. You can also type your username instead.

Thank you!
I got it. When I did it with just the -R it checked as if it worked but no change in the drive.
for some reason when I did --recursive and --verbose it said ownership of lost and found and games was retained by usul75:usul75.
I know verbose is the reason I got the output telling me what happened instead of just the blank line but for some reason it actually worked. I know it was probably some symantic error in the drive path or something but I don’t see it. Whatever. It worked this time thank you!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.