Canon MF644Cdw: no exact driver match

Trying to install Canon 644Cdw in Manjaro 20.2 Nibia with kernel 5.8.18-1 x86_64. I have installed cndrvcups-lb 3.70-1 but am unable to find my printer in the list. I tried a printer that is close, the MF632C/MF634C, and it installs successfully. In the options, it is able to look at consumables and so it appears the driver is communicating with the printer. However, when I print nothing comes out. The printer queue show the job processing and then gone. On the printer itself, its status says it printed but no paper came out. BTW, other Windows machines are printing without problem.

I have pulled down the Canon driver kit for MF644Cdw but it only supports RPM and debian.

Is there an updated cndrvcups-lp driver I should be using? Am I doing something wrong?

Sounds like the same driver:

@Yochanan, Thanks for your response. I have built cnrdrvcups-sfp from AUR but I’m not 100% sure what to do next. I have tried installing using CUPS via http://localhost:631/ but I do not find my printer in the list.

These are my steps in CUPS:
Administration -> Add Printer -> IPP printer -> enter ip (ipp:// -> Canon

Not sure what to do.

Hi. There are several versions of Canon UFR II printer driver in the AUR. According to Canon support site your printer needs UFR II/UFRII LT Printer Driver for Linux V5.20. File name for that driver is linux-UFRII-drv-v520-usen-05.tar.gz.
This version corresponds to cnrdrvcups-lb AUR package. Maybe that will work.

1 Like

@kainonergon, I agree and I tried that package and found many printers that were close to the one I have but I couldn’t get any of them to work.

Only thing I can think of is I am not installing the package correctly. What is the proper way to take this package, install it and then use it in CUPS?

I installed a printer that uses the UFR II/UFRII LT printer driver and it installs successfully. When I print, the CPUS error_log show this error:
E [24/Nov/2020:23:51:30 -0800] [Job 34] src = bidiCommon.c, line = 1223, err = 0¥nDEBUG: Connecting to
and the printer show error #853.

CUPS Admin page gives this error:
completed at
Tue 24 Nov 2020 11:51:33 PM PST
“src = bidiCommon.c, line = 1223, err = 0¥nDEBUG: Connecting to”

Printer is working - Okular, maybe not.

I installed the driver for the Canon-MF633C-635C using the cnrdrvcups-lb AUR package and first attempt still didn’t work. In desperation, I tried another pdf document using Okular and it printed. Then I retried my original pdf document but this time from FireFox, and it printed, so it seems to be something with Okular.

This pdf is newly created, so I can only assume there is some incompatibility with Okular and newer pdf files.

Thank you to @kainonergon and @Yochanan for your responses.

EDIT: marking @kainonergon as the solution as the package with the closest match to the printer I needed is cnrdrvcups-lb built from AUR.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.