Canon ImageClass MF216n



Hi guys,

Having an issue trying to install a printer. The printer in question is the Canon ImageClass MF216n. I’m using the deepin edition of manjaro. The issue is the driver does not show up in the list when I try to add the printer. I have tried adding the cndrvcups-lb and -bin packages from the aur and restarted both times after installing but the printer driver is still not listed.

Any help would be awesome.


I searched this keyword with “linux” and found this in AUR for example
But I would edit the PKGBUILD to add this link as source
Becauser that is the model from the Canon website


Tried your suggestion and it did not work. The printer is not in the list. I had installed the package that you mentioned without any modifications and it did not work either.


Can you show your modified PKGBUILD, please?


You can also show a Screenshot at what point “it is not in the list”.


Maybe it is worth looking into this one

There seem to be .deb packages in the archive. You can try if they work on a Debian based distro.



Tried the one that it has listed as recommended but the printer does not print with that.


I think the recommended one is the right one, the drivers use to have “round” numbers. Edit: If you look up the name for the Windows driver for the model - it is MF210MFDriverV2120W64usEN.exe So, MF210 should be right. It might be not the driver which prevents you from printing. Maybe some packages aren’t installed. Can you install the (meta)package manjaro-printer and gtk3-print-backends, please, and check if you can print after reboot.

I extracted the driver archive and it looks like the package in AUR does it correctly. They just use UK English version in AUR the rest seems the same.


manjaro-printer was installed already. Installed gtk3-print-backends, did not help. Status of test page is at Processing for 5 minutes.

Your probably right about the recommened printer. But it doesn’t print.:confused:


You can also try to set up the printer differently by selecting the .ppd file. It might work with the package cups-filters installed, or not. Install cups-filters anyway, maybe that’t the only thing missing.

Extract the archive from Canon website, then extract the *amd64.deb archive, then the PPD file should be on this (relative) path:



cups-filters was already installed. Tried adding via the PPD file. No change.


Then I would try a Debian (or RPM) based distro to see if the printer would work there. It would be nice if you report here your result. This would help other users with a similar model if they find your post.


I know the printer works cause it works under a windows machine. I was hoping to get it to work under manjaro.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.