Canon DSLR webcam setup - Webcamoid & OBS can't see my camera, could it be a kernel issue?

My DSLR is very naughty, Manjaro doesn’t pick up the video feed when I try to use it as a webcam (it does work for taking still photos) - Canon EOS Rebel T2i (EOS 550D) bad boy. - Could it be a kernel incompatibility? 5.15.2-2 linux515

I figure it’s either a command that updates the configuration files somewhere along the chain that I’m in need of, either that or the kernel isn’t compatible.

  • Cheese :x:
  • Kamaso :x:
  • Webcamoid :x:
  • OBS :x:
  • KDE cam tester :white_check_mark:
  • Engtangle still shooter app :white_check_mark:

i did check the arch wiki
Webcam setup - ArchWiki

useless background;
The only programs that identify the DSLR plugged in by USB is the KDE “Digital Camera” identifyer, And Entangle works, but only for taking still photos. (except for when I tried a video capture card, but that just showed the phone display)
I installed a lot of other apps and I tried a lot of commands, and I read a lot of wiki, but in the end I wasn’t able to connect my DSLR (as a webcam) to Webcamoid or OBS last night.

It looks like that this needs special software aka drivers that are only made available for Windows and Mac.

Canon EOS Webcam Utility Software - Canon Deutschland

Try AUR (en) - entangle and see if that does what you need.

Also, do you have gphoto2 installed?
You could use a command like this:

gphoto2 --stdout --capture-movie | ffmpeg -i - -vcodec rawvideo -pix_fmt yuv420p -threads 0 -f v4l2 /dev/video0

depending if is video0 or video1 … or whatever.

Also, the same way you can use VLC to capture video from it, and then in OBS capture the VLC output.

entangle works but it doesn’t do what I want, just still pics, no video.
I was reading about gphone but someone told me to be careful about following random blogs.

thanks. I saw that it had commands with a lot of parameters seemingly and that’s a lot of “–” and I forget if hat , well yeah I guess I don’t know) it’'s interesting that that command requires so many

they made some stuff for linux

what’s the best way to find if it’s video0 again?
dmesg? ummm i forget a few other commantds

I wasn’t getting anything like vlc, obs or webcamoid to see it. I got a gphoto error of some kind some i’m going to reinstall. you think that could help?

v4l2-ctl --list-devices
And then to list the configurable settings of a video device:

v4l2-ctl -d /dev/videoX --list-ctrls where X is the number of the video device.

Reinstall will not help, you have to make sure is properly detected. I see in the tutorial they use v4l2loopback-dkms and is in our repositories.
That means you have to install the linux-headers for your running kernel ? and then that dkms … not sure exactly.

what’s the best way to find if it’s video0 again?
dmesg? ummm i forget a few other commantds

is the simplest and more efficient way.

1 Like

Actually, they didn’t. :wink:
(if by “they” you mean Canon, providing a program or driver …)

But if gphoto2 is able to capture from your DSLR
this can be used to make it work
like shown in the video
with the string of commands that @bogdancovaciu mentioned
which seems to be the same as what is shown in that video.

Looking at:

gPhoto - Projects :: libgphoto2 :: supported cameras

your DSLR seems to be supported to do this.

Good for you!
Good luck!

1 Like

Yeah I’ve been studying and going through what people have said and I thought that too, the v4l2loopback kernel driver for our distribution is certainly different. Is that what you mean to say? ( and hell no, I’m not doing a wrapper, modified header, whatever sh*t, that sounds as needlessly inelegant as I’m not inclined) .

Actually, looking at our repository, I notice that we do have that name v4l2loopback-dkms in our official repositories, but it’s not described as a “kernel driver” but as he called it but rather

The v4l2loopback module is a kernel module . In order to build it, you must have the kernel headers installed that match the linux kernel with which you want to use the module (in most cases this will be the kernel that you are currently running). Please note, that kernel headers and kernel image must have exactly the same version.

So perhaps rather than the header, the kernel number has to match exactly and I don’t see a kernel with anything close. Which begs the question, why is it “Official Repositories?”

Oh yeah I meant the ‘Linux Community’ not the folks at canon.

My camera is supported but it seems like I can do it because it must have the kernel headers installed that match the linux kernel" and the loopback number doesn’t match with the kernels.

I guess there a potential ‘GHETTO RIG’ solution which involves just using a capture card on the camera’s screen, that is if you can leave it in “Live View shoot” mode and control it remotely so that you you don’t interrupt the feed with GUI.

I think there is a misunderstanding here on your part.
That module needs to be built.
In order to be able to build it, you must have the kernel headers installed.
(and the “base-devel” group of packages …)

Each kernel version has it’s corresponding kernel header package.
Just as easy to install as any other package.

Just look into how to set up and use dkms - I don’t know if it is any different on Manjaro than it is on Arch - but if it is, it can’t be much.
They have it all nicely described (as usual) in their wiki, which is an excellent source of information.

1 Like

You’re right, I’m putting it together but I had to step away for a while just because it’s a lot of new information for me.