Cannot upgrade due to error

Can not upgrade with error message, after pacman -Syyu

:: Starting full system upgrade...
warning: appstream-glib: local (0.7.18-2) is newer than extra (0.7.18-1)
warning: pacman: local (5.2.2-5) is newer than core (5.2.2-4)
warning: zsh-theme-powerlevel10k: local (1.14.6-1) is newer than community (1.13.0-1)
 there is nothing to do

would appreciate help.

You switched branches?
When you get is newer than then you use an extra u in the command. Also, to be sure all is ok, update mirrors also. That means you can run this command:
sudo pacman-mirrors -f5 && sudo pacman -Syyuu


I ran your command and I get this:

call to execv failed (No such file or directory)
error: command failed to execute correctly

I tried sudo pacman -S execv and error, target not found…

execv is not a program. It’s a glibc builtin.

I am running
sudo chmod +x /usr/share/libalpm/scripts/gtk-update-icon-cache
pacman -S gtk3

and repeated your command and that resolved the problem, thanks.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.