Cannot Upgrade Anything

Just opened Manjaro after a time away from this computer. Package manager suggests a number of upgrades but these cannot be actioned.

Can’t seem to do/update anything, keys etc all fall over

You could try to delete confuse-3.3-2-x86_64.pkg.tar.zst manually by running sudo rm /var/cache/pacman/pkg/confuse-3.3-2-x86_64.pkg.tar.zst

1 Like

Give this a try to refresh the keys:

  1. Remove old (and possibly broken) keys by entering this command:

sudo rm -r /etc/pacman.d/gnupg

  1. Reinstall keyrings including the latest keys:

sudo pacman -Sy gnupg archlinux-keyring manjaro-keyring

  1. Initialize the pacman keyring:

sudo pacman-key --init

  1. Load the signature keys:

sudo pacman-key --populate archlinux manjaro

  1. Refresh and update the signature keys:

sudo pacman-key --refresh-keys

  1. Clear out the software packages downloaded during the aborted installation (optional):

sudo pacman -Sc

then sudo pacman -Syyu

Tried but results seem the same

keeps downloading but not upgrading with error mesages

warning: Public keyring not found; have you run ‘pacman-key --init’?

Did you do all the steps listed above?

The error after your last try is:

error: failed to commit transaction (conflicting files)

There are several threads here that suggest what to do, f.e.:

btw. 2 GB of updates? When was the last time you updated the system?
anyways good luck :wink:

1 Like

October I guess?

The link above doesn’t resolve. There are hundreds of lines of errors and keep getting the message no path to…

Looks like a reinstall os job?

Is there a way to push through one at a time using package manager?

Have you tried the “I don’t care” way, as mentioned in the linked thread?

sudo pacman -Syu --overwrite '*'

Have you tried the “I don’t care” way, as mentioned in the linked thread?

sudo pacman -Syu --overwrite ‘*’

how would this apply to this situation?

gcc: /usr/bin/c99 exists in filesystem

sudo pacman -Syyu --overwrite=/usr/bin/c99

and then I have to manually enter this for each one that is an issue? must be a quicker way than this?

No, you don’t have to use this command for every file that “exists in the filesystem” as mentioned in the output. You only need to run it once and hopefully it will take care of everything.

So, open a terminal window and run

sudo pacman -Syu --overwrite '*'

to update your system.