Cannot update to Plasma 5.20.x

I tried (both with pacman and with yay) to update Plasma from 5.19 to 5.20, but when checking package integrity I get the following:

What happened here? Did the people at kde changed the name from plasma-desktop to plasma-workspace and now Pacman is going:

skidaddle skiddodle,
craight croog crate,
your “professionally made operating system that is a suitable replacement for Windows or MacOS” can’t even do a basic update

Only you know what it is that did this to your system ─ presumably you had tried to upgrade Plasma by way of the -git packages earlier, but we don’t know that unless you tell us.

That said, the quick & dirty solution ─ no warranty; if it breaks your system then you get to keep all the pieces ─ is this… :arrow_down:

sudo pacman-mirrors -f 5 && sudo pacman -Syyu --overwrite='/usr/*'

Hello and welcome,

Even tho that statement from you is quite unfriendly, here is my 2¢ for you: don’t do that to any distro developers, forum or other channels. :wink:

None of my installs ever got the exists in filesystem … hence, as mentioned above, it depends on what you previously did.


Appreciate the work you are doing, guys, do not get me wrong, just throwing a bit of cutting irony in the middle. I apologize if that somehow offended you or your work, Manjaro, which again, I stress, I use as my mainly driver. It’s just that it’s frustrating sometimes. Yes, I agree it’s probably my fault to have bought an Nvidia and gone with the KDE flavor, although this is a different story and I am not sure how this has anything to do with the Plasma Update.

I did not, everything is from the official repositories, that’s why I made this post in the first place.

One thing I did that might have broken the update: I installed a kvantum theme (kvantum again installed from the official repositories). Maybe this messed up with something? It shouldn’t have though.

This, albeit dangerous, was the working solution. After a backup and running:

Thanks, neat GRUB theme

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.