Cannot update on Manjaro Openbox 0.8.6 install - elogind, pm-utils, systemd

Can’t install this update:

:: Volledige systeemsupgrade starten...
:: pm-utils vervangen met community/elogind? [J/n] j
afhankelijkheden oplossen...
zoeken naar conflicterende pakketten...
:: elogind en systemd-sysvcompat conflicteren. systemd-sysvcompat verwijderen? [j/N] j
:: dbus-elogind en dbus conflicteren (libdbus). dbus verwijderen? [j/N] j
:: polkit-elogind en polkit conflicteren. polkit verwijderen? [j/N] j
:: libeudev en libsystemd conflicteren (libudev.so). libsystemd verwijderen? [j/N] j
:: eudev en systemd conflicteren (udev). systemd verwijderen? [j/N] j
fout:fout bij het voorbereiden van transactie (kan niet aan afhankelijkheden voldoen)
:: chromium: vereist systemd
:: device-mapper: vereist systemd
:: udisks2: vereist systemd
:: lvm2: vereist systemd
:: bluez-utils: verwijderen van systemd doorbreekt afhankelijkheid 'systemd'
:: colord: verwijderen van systemd doorbreekt afhankelijkheid 'systemd'
:: crda: verwijderen van systemd doorbreekt afhankelijkheid 'systemd'
:: cups: verwijderen van systemd doorbreekt afhankelijkheid 'systemd'
:: dhcpcd: verwijderen van libsystemd doorbreekt afhankelijkheid 'libsystemd'
:: lib32-systemd: verwijderen van systemd doorbreekt afhankelijkheid 'systemd'
:: libatasmart: verwijderen van libsystemd doorbreekt afhankelijkheid 'libsystemd'
:: libgudev: verwijderen van libsystemd doorbreekt afhankelijkheid 'libsystemd'
:: libinput: verwijderen van systemd doorbreekt afhankelijkheid 'systemd'
:: libmbim: verwijderen van systemd doorbreekt afhankelijkheid 'systemd'
:: libpulse: verwijderen van systemd doorbreekt afhankelijkheid 'systemd'
:: libusb: verwijderen van systemd doorbreekt afhankelijkheid 'systemd'
:: libwacom: verwijderen van systemd doorbreekt afhankelijkheid 'systemd'
:: lockdev: verwijderen van systemd doorbreekt afhankelijkheid 'systemd'
:: media-player-info: verwijderen van systemd doorbreekt afhankelijkheid 'systemd'
:: mkinitcpio: verwijderen van systemd doorbreekt afhankelijkheid 'systemd'
:: modemmanager: verwijderen van systemd doorbreekt afhankelijkheid 'systemd'
:: netctl: verwijderen van systemd doorbreekt afhankelijkheid 'systemd'
:: openvpn: verwijderen van libsystemd doorbreekt afhankelijkheid 'libsystemd'
:: pcmciautils: verwijderen van systemd doorbreekt afhankelijkheid 'systemd'
:: pcsclite: verwijderen van systemd doorbreekt afhankelijkheid 'systemd'
:: procps-ng: verwijderen van libsystemd doorbreekt afhankelijkheid 'libsystemd'
:: rpcbind: verwijderen van libsystemd doorbreekt afhankelijkheid 'libsystemd'
:: rtkit: verwijderen van systemd doorbreekt afhankelijkheid 'systemd'
:: subversion: verwijderen van systemd doorbreekt afhankelijkheid 'systemd'
:: syslog-ng: verwijderen van systemd doorbreekt afhankelijkheid 'systemd'
:: udisks: verwijderen van systemd doorbreekt afhankelijkheid 'systemd'
:: upower: verwijderen van systemd doorbreekt afhankelijkheid 'systemd'
:: util-linux: verwijderen van libsystemd doorbreekt afhankelijkheid 'libsystemd'
:: xdg-user-dirs: verwijderen van systemd doorbreekt afhankelijkheid 'systemd'

Should i force this?

Edit:
This system was installed using Manjaro Openbox 0.8.6 image, and it’s still running Openbox.

I read this: Replace eudev-systemdcompat with community/eudev-systemd and libeudev-systemd?

and i do have lxsession installed, is that a problem?

Here is the answer:


also here:

You see, with some search you can find an answer, especially if you use terminal output for the search.

Thanks, that worked!
Searched for a good 15 minutes, but did not find those topics though.

2 Likes

It is also because your terminal output is in Dutch. For searching error messages better get English terminal output with LC_ALL=C before the command

1 Like

Nice, i was wondering how to do that. Will try that next time.

Yeah how about us non-systemd users :slight_smile:
This has gotten interwoven and confusing now.

I’m not even sure what these are, especially elogind. Is all of openrc being moved into the community repos?

[sudo] password for ruben:
:: Synchronizing package databases…
core is up to date
extra is up to date
community is up to date
multilib is up to date
:: Starting full system upgrade…
:: Replace cgmanager-openrc with community/elogind-openrc? [Y/n] n
:: Replace consolekit with community/elogind? [Y/n] n
:: Replace consolekit-openrc with community/elogind-openrc? [Y/n] n
:: Replace pm-utils with community/elogind? [Y/n] n
:: Replace polkit-consolekit with community/polkit-elogind? [Y/n] n
:: Replace udev-openrc with community/eudev-openrc? [Y/n] n
resolving dependencies…
looking for conflicting packages…
warning: removing ‘device-mapper’ from target list because it conflicts with 'device-mapper-nosystemd’
warning: removing ‘lvm2’ from target list because it conflicts with ‘lvm2-nosystemd’
:: device-mapper-nosystemd and device-mapper are in conflict. Remove device-mapper? [y/N] N
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: device-mapper-nosystemd and device-mapper are in conflict
[ruben@flatbush ~]$

All users should use the search function in case of doubt
https://forum.manjaro.org/search?q=elogind

that is how I found this thread.

Funny that you didn’t find this one

of course I did and I posted in there because that method didn’t work.

Everybody can see where you posted when. This can explain why nobody answered so far.
In the future open a new topic before you try any thread hijacking.
And while this issue with elogind is solved


you are posting about it as if it wasn’t solved - this is beyond good and evil!

I have no idea why you are being so hostile but I did get an answer, and a correct one in the new thread I created, which I created after I looked over everywhere else and didn’t see an usable answer. With that, I’m done with this back and forth as it serves no purpose. I have no ill will towards you. Peace where you walk brother…

Forum kindly sponsored by Bytemark