Cannot start breezy after Manjaro update on 11/2/2022

After doing pamac update this morning, I cannot run the breezy revision control system. When I try to start breezy, I get the following error message:

Error: PyErr { type: <class 'ModuleNotFoundError'>, value: ModuleNotFoundError("No module named 'breezy'"), traceback: None }

I tried to uninstall and reinstall breezy with the following:

$ sudo pamac remove breezy
$ sudo pamac install breezy

But that did not help.
Is this a known issue?
I tried to create a topic under Development, but my account seems blocked from doing that.


Welcome to the forum! :wave:

By doing what, exactly?

There’s a reason for that. Don’t worry, #support the right place.

I tried to start breezy by typing brz status at the bash command prompt.
When I do, I get the following:

$ brz st
brz: ERROR: Couldn't import breezy and dependencies.
Please check the directory containing breezy is on your PYTHONPATH.

Error: PyErr { type: <class 'ModuleNotFoundError'>, value: ModuleNotFoundError("No module named 'breezy'"), traceback: None }

It appears you’re mixing local and system Python packages. Please see: [root tip] [How To] Avoid common pitfalls as developer

Thank you for that clue. It seems that you are right. I run Python for a Python virtualenv.
When I remove that virtualenv bin directory from my PATH environment variable, my system runs Python from /usr/bin, and breezy (brz) works.

I’ll have to figure out what to do about that.

Thanks again for your help.


One more comment – The following seems to work:

$ PATH=/usr/bin brz st

Effectively, the above uses a temporary PATH environment variable, and forces brz to execute the Python in /usr/bin.

But, that’s a bit of a kludge, isn’t it? Seems like there should be a better way.

I tried to install breezy in my Python virtualenv, but in order to do so, it wants me to install the rust compiler. Maybe I’ll have to do that.

OK. I installed rust with pamac. Then I installed breezy in my virtualenv with Python pip.
So, now I’m executing brz from my virtualenv, and that works.

Thanks again.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.