Cannot save files on TexMaker

#1

I tried to google this issue, but all in vain. If there is already a topic of this (that I missed), could you please link it in here?

The problem:
If I try to save files on TexMaker, the program freezes and does not save the file. I have to kill the process.

What have I tried (but didn't work):
I) Checked rights to save files on the directory

  • For some reason they were locked for regular users -> I run pkexec chown -R -c ${USER}:users ${HOME} to fix it. (Just in case, I also run the chmod xx foo for the directory.)

However, the problem persisted and I continued to try the following:

IIa) Reinstalling TexMaker
IIb) Downgrading TexMaker
IIIa) Removing TexMaker and installed Kile instead
IIIb) Downgrading Kile

It is starting to look like I am missing something crucial for the problem. I really need to get it working, but I don't know how and need help. Thank you in advance for all the tips/comments.

Note:
I previously had the same problem with LibreOffice. I solved the problem by downgrade libeoffice but as the list above suggest, it didn't work this time. This is the reason why I tried downgrade command for the problem + why I think there is something more behind it.

#2

At what point does it freeze?

Are your packages all fully up-to-date? Worth checking just to make certain:

sudo pacman-mirrors -f3
sudo pacman -Syyu
#3

Right after I hit save button (after I give the name to the file e.g. foo.tex). So it kind of freezes for the saving process.
Bonus:
I tried waiting for a long time (+30min) and still nothing. I have tried different locations and different file sizes. No difference.

They should be, but just in case I run the commands you wrote. The problem persists.

Note:
I have added LibreOffice and TexMaker into IgnorePackage. LibreOffice because the newest version does not work on my laptop so no use to keep it up-to-date (+ I highly doubt it affects the functionality of TexMaker). However, I installed Kile and took it away from IgnorePackage. So I have (sort of) a control point for trouble shooting (as Kile ~ TexMaker). So now Kile is up-to-date and TexMaker is not. If this is a stupid idea, let me know.

#4

Have you tried launching from a terminal to see if it reports any errors?

#5

Not yet, but I will try and report here.

EDIT:
Sorry for delay, I was not on laptop. And no. Zero (error) messages. It just opens nicely (and the problem persists).
EDIT2:
Edited too fast as I forgot to test both TexMaker and Kile. No errors on TexMaker, but Kile gave this:

QFSFileEngine::open: No file name specified
sonnet.core: No language dictionaries for the language: "en_GB"
sonnet.core: No language dictionaries for the language: "en_GB"
sonnet.core: No language dictionaries for the language: "en_GB"
sonnet.core: No language dictionaries for the language: "en_GB"
sonnet.core: No language dictionaries for the language: "en_GB"
Killed
#6

Both working here, I know very little latex:

\documentclass{article}
\begin{document}
  Hello World!
\end{document}

Saving fine.