Cannot run windows anymore

Do you have os-prober installed?

At Manjaro terminal, provide

test -d /sys/firmware/efi && echo UEFI || echo BIOS
findmnt

Also at manjaro file manager, check windows partition (sda3?)
See if there is a file “bootmgr” (in main partition - no path).
Also check if there is a file “bootmgfw.efi” in path "/EFI/Microsoft/Boot/bootmgfw.efi"
or this file (bootmgfw.efi) in sda1 in /Microsoft/Boot/bootmgfw.efi

Gohlip is trying to find out if you have installed your system in uefi mode and if windows uefi bootloader is still intact.

If you have osprober installed, just rerunning

 sudo update-grub

Can sometimes help, even if it did not work the first time. Sometimes, very rarely, the script misses Windows for no apparent reason, but finds it on next try. But you have probably already tried it more than once.

Can you still start windows by setting it first in boot order in your uefi?

Did this happen with update or immediately when you installed manjaro?

Good idea. And actually, my first thinking thought was that his windows boot was destroyed when he installed Manjaro by formating the $esp partition.; but we just cannot jump to first thinking suspicion without finding out more.

If windows bootloader is booked, the following link may be helpful: https://blog.d0zingcat.xyz/2015/09/28/Windows/How%20to%20repair%20the%20EFI%20Bootloader%20in%20Windows%2010/

But it is still not sure. Follow Gohlips advice and determine the cause first.

[quote=“Chrysostomus, post:19, topic:14797”]
If windows bootloader is borked
[/quote] and you fix it with Chrysotomus link, then recover Manjaro boot by using this. That’s the easy part.

Good luck.

installed

test -d /sys/firmware/efi && echo UEFI || echo BIOS

UEFI

findmnt
TARGET                           SOURCE      FSTYPE      OPTIONS
/                                /dev/sda6   ext4        rw,noatime,data=ordered
├─/proc                          proc        proc        rw,nosuid,nodev,noexec,relatime
│ └─/proc/sys/fs/binfmt_misc     systemd-1   autofs      rw,relatime,fd=27,pgrp=1,timeout=0,minproto=5,maxproto=5,direct
│   └─/proc/sys/fs/binfmt_misc   binfmt_misc binfmt_misc rw,relatime
├─/sys                           sys         sysfs       rw,nosuid,nodev,noexec,relatime
│ ├─/sys/kernel/security         securityfs  securityfs  rw,nosuid,nodev,noexec,relatime
│ ├─/sys/fs/cgroup               tmpfs       tmpfs       ro,nosuid,nodev,noexec,mode=755
│ │ ├─/sys/fs/cgroup/systemd     cgroup      cgroup      rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/usr/lib/systemd/s
│ │ ├─/sys/fs/cgroup/net_cls     cgroup      cgroup      rw,nosuid,nodev,noexec,relatime,net_cls
│ │ ├─/sys/fs/cgroup/freezer     cgroup      cgroup      rw,nosuid,nodev,noexec,relatime,freezer
│ │ ├─/sys/fs/cgroup/devices     cgroup      cgroup      rw,nosuid,nodev,noexec,relatime,devices
│ │ ├─/sys/fs/cgroup/blkio       cgroup      cgroup      rw,nosuid,nodev,noexec,relatime,blkio
│ │ ├─/sys/fs/cgroup/memory      cgroup      cgroup      rw,nosuid,nodev,noexec,relatime,memory
│ │ ├─/sys/fs/cgroup/pids        cgroup      cgroup      rw,nosuid,nodev,noexec,relatime,pids
│ │ ├─/sys/fs/cgroup/cpuset      cgroup      cgroup      rw,nosuid,nodev,noexec,relatime,cpuset
│ │ └─/sys/fs/cgroup/cpu,cpuacct cgroup      cgroup      rw,nosuid,nodev,noexec,relatime,cpu,cpuacct
│ ├─/sys/fs/pstore               pstore      pstore      rw,nosuid,nodev,noexec,relatime
│ ├─/sys/firmware/efi/efivars    efivarfs    efivarfs    rw,nosuid,nodev,noexec,relatime
│ ├─/sys/kernel/config           configfs    configfs    rw,relatime
│ ├─/sys/kernel/debug            debugfs     debugfs     rw,relatime
│ └─/sys/fs/fuse/connections     fusectl     fusectl     rw,relatime
├─/dev                           dev         devtmpfs    rw,nosuid,relatime,size=4033244k,nr_inodes=1008311,mode=755
│ ├─/dev/shm                     tmpfs       tmpfs       rw,nosuid,nodev
│ ├─/dev/pts                     devpts      devpts      rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000
│ ├─/dev/hugepages               hugetlbfs   hugetlbfs   rw,relatime
│ └─/dev/mqueue                  mqueue      mqueue      rw,relatime
├─/run                           run         tmpfs       rw,nosuid,nodev,relatime,mode=755
│ └─/run/user/1000               tmpfs       tmpfs       rw,nosuid,nodev,relatime,size=807672k,mode=700,uid=1000,gid=1000
│   └─/run/user/1000/gvfs        gvfsd-fuse  fuse.gvfsd- rw,nosuid,nodev,relatime,user_id=1000,group_id=1000
├─/boot/efi                      /dev/sda1   vfat        rw,noatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shor
└─/tmp                           tmpfs       tmpfs       rw,nosuid,nodev

yes it’s sda3

Are the files “bootmgr” or “bootmgfw.efi” there?
Can you remember if you formatted the $esp (sda1) during Manjaro installation?
If the files are not there or you recall formatting $esp, then follow Chrysostomus link and then recover Manjaro grub by booting up Manjaro livecd and at terminal,

sudo mount /dev/sda6 /mnt
sudo mount /dev/sda1 /mnt/boot/efi
sudo grub-install --target=x86_64-efi --efi-directory=/mnt/boot/efi --bootloader-id=manjaro --boot-directory=/mnt/boot --recheck --debug

found at /run/media/xfce4mj/OS

Wait! don’t use Chrymostomus link.
Wait for my next post.

ok i will

But why “/run/media/xfce4mj/OS” ?
Is that sda3? Is that windows partition?

got it by PCManFM find tool
at / path

yes just it
win on sda3

cd /run/media/xfce4mj/OS

ls
 Boot      devlist.txt   hiberfil.sys   PerfLogs        'Program Files (x86)'   swapfile.sys                 Windows
 bootmgr   eSupport      Intel          ProgramData      Recovery              'System Volume Information'
 BOOTNXT   Finish.log    pagefile.sys  'Program Files'  '$Recycle.Bin'          Users

PcManFM - Tools - Find

so
if i add a new path to seatch in, i can find those into pic

/ is manjaro
sda3 is win
sda8 is sparkylinux

\

Now, do this…
Go to Manjaro terminal,

sudo touch /boot/grub/custom.cfg

Open up the newly created file custom.cfg

gksu gedit /boot/grub/grub.cfg

(or, if on kde) “kdesu kate /boot/grub/grub.cfg”
(or if using leafpad) “sudo leafpad /boot/grub/grub.cfg”

Add the following to the open custom.cfg

menuentry "Windows "  {
  insmod part_msdos
  insmod part_gpt
  insmod ntfs
  set root='hd0,gpt3'
  search --no-floppy --fs-uuid --set=369C34DB9C349779
  ntldr /bootmgr
}

Save file. Reboot, find the new entry at bottom of grub menu.
Boot this. Let us know if this boots.

ps: Your system setup is wrong. (And it’s bad)
but let’s discuss this (if you want) after you boot windows first.

Forum kindly sponsored by Bytemark