Cannot run Flatpak nor Snap applications

Hello everyone,

After using Manjaro with xfce for a few months I installed Manjaro with KDE Plasma on another machine (both installations through Architect). I am unable to integrate Flatpak into the Plasma machine.
I can install packages through Pamac without problem, installing through CLI gives a warning that:
are not in XDG_DATA_DIRS.
After installation I can run application neither through Pamac, nor can it be found in my programs. It can be run through CLI by using:
flatpak run 'name'
So I thought that setting XDG_DATA_DIRS correctly should solve the problem. First I checked the value of this variable:
and it produces a single empty line. Arch wiki (1) states that it should default to /usr/local/share:/usr/share.
Also setting XDG_DATA_DIRS to /var/lib/flatpak/exports/share:/home/p/.local/share/flatpak/exports/share or /var/lib/flatpak/exports/share/:/home/p/.local/share/flatpak/exports/share/ through:
export XDG_DATA_DIRS='one of the above strings here'
ensures no warning before installation. Rebooting resets XDG_DATA_DIRS to nothing but apps are still not to be found.

In case of Snap it installs apps both through Pamac and CLI without problem but Pamac cannot run nor uninstall packages. Also installed snaps are not to be found in my programs.

Did I mess up something during installation? I found some similar issue here (2). How could I get Flatpak and Snap to work?

Flatpak 1.8.3
snap 2.47.1-1 snapd 2.47.1-1 series 16 manjaro - kernel 5.10.0-1-MANJARO
(1) https wiki(dot)archlinux(dot)org index(dot)php XDG_Base_Directory
(2) https forum(dot)manjaro(dot)org t new-update-made-my-flatpak-apps-disappear 37166

1 Like

The same thing happened to me after an update a few days ago. Flatpaks and ~/.local/bin/ aren’t being added to $PATH for me on kde

Same thing here for me. I am unable to launch Flatpak apps from the menu. They only launch through the cli. I’ve tried making the changes similar to above but no luck.

I have the same error. No entrys of all flatpak applications in my menu.

I use fish and found some entrys on github

for me the solution was to put this lines into my

set -l xdg_data_home $XDG_DATA_HOME ~/.local/share
set -gx --path XDG_DATA_DIRS $xdg_data_home[1]/flatpak/exports/share:/var/lib/flatpak/exports/share:/usr/local/share:/usr/share

for flatpakdir in ~/.local/share/flatpak/exports/bin /var/lib/flatpak/exports/bin
if test -d $flatpakdir
contains $flatpakdir $PATH; or set -a PATH $flatpakdir