cannot restart / shutdown with linux 5.1 kernel

Hi,

I'm having this very weird problem. I cannot restart / shutdown while using 5.1 kernel (5.0 also tested,same thing :frowning: ).when i press restart i just get a blank screen.

4.19 works fine with no issues.

I'm very new to kernel debugging,please say what info is needed and i will get it.

what i thought would be helpful:
journelctl log from the moment of restart press

i had to hard restart after 6 mins of waiting..

inxi -Fxxxz

System:    Host: maxfunc Kernel: 5.1.4-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.3.0 Desktop: KDE Plasma 5.15.5 
           tk: Qt 5.12.3 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: Gigabyte model: H310M H v: x.x serial: <filter> UEFI [Legacy]: American Megatrends 
           v: F12 date: 03/14/2019 
CPU:       Topology: 6-Core model: Intel Core i5-8400 bits: 64 type: MCP arch: Kaby Lake rev: A L2 cache: 9216 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 33708 
           Speed: 800 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 
Graphics:  Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] vendor: ZOTAC driver: nvidia v: 418.74 bus ID: 01:00.0 
           chip ID: 10de:1c82 
           Display: x11 server: X.Org 1.20.4 driver: nvidia compositor: kwin_x11 resolution: 1920x1080~60Hz 
           OpenGL: renderer: GeForce GTX 1050 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 418.74 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:a348 
           Device-2: NVIDIA GP107GL High Definition Audio vendor: ZOTAC driver: snd_hda_intel v: kernel 
           bus ID: 01:00.1 chip ID: 10de:0fb9 
           Sound Server: ALSA v: k5.1.4-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte driver: r8168 
           v: 8.047.01-NAPI port: 3000 bus ID: 02:00.0 chip ID: 10ec:8168 
           IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 1.13 TiB used: 14.74 GiB (1.3%) 
           ID-1: /dev/sda vendor: Western Digital model: WD10EZEX-00MFCA0 size: 931.51 GiB speed: 6.0 Gb/s 
           rotation: 7200 rpm serial: <filter> rev: 1A01 scheme: MBR 
           ID-2: /dev/sdb vendor: A-Data model: SU650 size: 223.57 GiB speed: 6.0 Gb/s serial: <filter> rev: 1b10 
           scheme: MBR 
Partition: ID-1: / size: 215.69 GiB used: 8.00 GiB (3.7%) fs: ext4 dev: /dev/sdb2 
           ID-2: /home size: 915.89 GiB used: 6.74 GiB (0.7%) fs: ext4 dev: /dev/sda1 
           ID-3: swap-1 size: 3.42 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdb1 
Sensors:   System Temperatures: cpu: 56.0 C mobo: 27.8 C gpu: nvidia temp: 43 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 51% 
Info:      Processes: 204 Uptime: 13m Memory: 7.72 GiB used: 1.81 GiB (23.5%) Init: systemd v: 242 Compilers: 
           gcc: 8.3.0 Shell: bash v: 5.0.7 running in: konsole inxi: 3.0.34 

You need to try the latest version of any kernel before debugging that particular kernel series.

5.1 is currently at 5.1.8, so you should check whether that version has the same issue.

5.1.8 is not available in setting :frowning:

Your system is outdated.Please update via terminal using this command
sudo pacman-mirrors -f5 && sudo pacman -Syyu

Tried 5.1.8. same problem. :frowning:

Why do so many insist on swimming upstream against the current. If the new kernels are not booting for you file a bug report and return to kernel 4.19 until your problem has been resolved.

There's no fine print in the Linux GPL saying your kernel will self destruct your computer unless you run the newest versions of the kernel. :smile:

1 Like

that's what i want to do. I just don't know how.

The reason for bug should be found, it could be anything (drivers? graphics? grub? idk 0_0).The key is in journelctl log, i don't know what to look for.

update: with latest updates installed as of now, the problem still persists.

I'm using it as i have no option really :expressionless:

I would start by looking for error messages in the journal.

In your case because it does not boot look at the logs from the previous failed boot(s) or attempted shutdowns.

To look at error level messages from the previous boot use
journalctl -b-1 -p3
The number following -b being how many boots ago (so two boots ago use -b-2). -p3 means messages of priority error or above, if you want a bit more try -p4 being of warning or above (parameter runs from 1 to 7).

Also when attempting to shutdown I would recommend leaving it longer to see if it will finally shutdown (perhaps catching more errors along the way). I have certainly experienced shutdown taking around 15 minutes when I had problems with unmounting partitions, although your experience may differ.

2 Likes

I got this output:

-- Logs begin at Tue 2019-06-11 02:39:48 IST, end at Fri 2019-06-14 00:53:33 IST. --
Jun 14 00:27:34 maxfunc kernel: iTCO_wdt iTCO_wdt: can't request region for resource [mem 0x00c5fffc-0x00c5ffff]
Jun 14 00:35:37 maxfunc kernel: INFO: task Xorg:563 blocked for more than 122 seconds.
Jun 14 00:35:37 maxfunc kernel:       Tainted: P           OE     5.1.8-1-MANJARO #1
Jun 14 00:35:37 maxfunc kernel: "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
Jun 14 00:35:37 maxfunc kernel: INFO: task Xorg:2365 blocked for more than 122 seconds.
Jun 14 00:35:37 maxfunc kernel:       Tainted: P           OE     5.1.8-1-MANJARO #1
Jun 14 00:35:37 maxfunc kernel: "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
Jun 14 00:37:09 maxfunc systemd[1]: Failed unmounting /tmp.


and it did restart after like 10min(didn't track time)

can this article be of any help?

Some tips to find the cause:
If you have a second drive/ssd or something simmilar, you could try a distro based on vanilla arch (e.g. Anarchy, ArcoLinux, Antergos, SwagArch and others) and check if the kernel is unbootable there aswell.
It boots -> Manjaro- or your-system-specific issue
It doesn't boot -> continue, its not directly related to Manjaro itself.
If it does not start there you could check if you can boot up the latest openSUSE Tumbleweed snapshot or Ubuntu 19.04 or later or Fedora 30 Workstation or later.
It boots -> general ArchLinux-related issue.
It doesn't boot -> Probably issue of the kernel itself, you should eventually file an issue to the kernel developers directly.

Two other common causes for slow shutdown/restart I've found recently:

1: Entropy pool exhaustion (most common one).
Have you enabled haveged? Without it entropy pool exhaustion can occur, leading to very slow shutdown/startup times.
If you haven't here's how:

sudo systemctl enable haveged

2. Lvm2-metad being mad
There is a bug in versions 2.02.184-3 or earlier of the lvm2 package (Part of ArchLinux' Core OS) which causes shutdown to get VERY slow when using Kernel 5.0.0 or newer.
Make sure you have installed lvm2 2.02.184-4 or newer to avoid this issue. (2.02.185 also works)

This seems to me to be the relevant clue. But I am not particularly skilled here.

I would try looking in the journal for messages about what causes/leads up to the problem with unmounting /tmp (and maybe compare to the corresponding section of the journal output from a successful 4.19 shutdown). It might also be useful to look at the journal logs from a failed boot for messages related to a failure to mount /tmp.

(I am assuming that you have only kernel modules installed from the manjaro repositories, if you have installed others please provide that information for anyone who may be able to help you further. :slightly_smiling_face:)