Cannot remove stubborn former Grub installation

I’m new to this, so definitely feel free to ask me to add any needed information. The previous user of this computer had Ubuntu installed with a Grub boot manager, and now I’m using Manjaro. Currently when I boot up my system I get the Grub rescue screen, and I’m 99% sure it’s because it defaults to the old Grub installation which I’m trying to delete. I have a working grubx64.efi installed, and using my flash drive boot manager I can get to it and successfully boot into Manjaro.
When I run

sudo efibootmgr -v

I get this:

BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 2001,0005,0007,0001,2002,2003
Boot0000* GRUB	HD(1,GPT,150af998-43d2-4600-8436-3ea51194254b,0x800,0x32000)/File(\EFI\GRUB\grubx64.efi)
Boot0001* Windows Boot Manager	HD(1,GPT,150af998-43d2-4600-8436-3ea51194254b,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot0002* USB HDD: SanDisk Cruzer	PciRoot(0x0)/Pci(0x14,0x0)/USB(1,0)/USB(1,0)/HD(1,MBR,0x0,0x4726f0,0x2000)RC
Boot0005* grubx64efi	PciRoot(0x0)/Pci(0x17,0x0)/Sata(2,0,0)/HD(1,GPT,150af998-43d2-4600-8436-3ea51194254b,0x800,0x32000)/File(\EFI\ubuntu\grubx64.efi)A01 ..
Boot0007* Windows Boot Manager	HD(1,GPT,150af998-43d2-4600-8436-3ea51194254b,0x800,0x32000)/File(\EFI\GRUB\grubx64.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}....................
Boot002E* manjaro	HD(1,GPT,150af998-43d2-4600-8436-3ea51194254b,0x800,0x32000)/File(\EFI\manjaro\grubx64.efi)
Boot2001* EFI USB Device	RC
Boot2003* EFI Network	RC

So essentially, I’m trying to set my computer to boot into 0000, when it insists on booting into what is currently 0005.
What’s confusing me though is that /EFI/ubuntu does not exist. When I mount /dev/sda1, the EFI folder looks like this:

# dir
Boot  GRUB  Microsoft  OEM

Things I’ve already tried:

In Manjaro:

sudo efibootmgr -Bb 0005
sudo efibootmgr -o 2001,0000,0005,0007,0001,2002,2003

In Windows administrator cmd:

bcdedit /set "{bootmgr}" path \EFI\GRUB\grubx64.efi
bcdedit /delete {whatever code it gives at that time}

and I already mounted my EFI partition and deleted the ubuntu folder, which is why it doesn’t show up.

Every time I try to remove the ubuntu boot manager on any program, I reboot and it comes back. Any new suggestions?