Cannot remove snapper .snapshot - rm -fvr fails

I have been a gentoo user for about 20 years now, so very familiar with the command line. I have also used Arch in the past. I am looking at Manjaro, which I really like with a brtfs Raid1 setup. All working fine.
Now for Snapshots:-
I am trying to improve my snapshot layout as per the Arch Snapper Wiki, but when I do rm -fvr /.snapper I get this: rm: cannot remove ..... : Read-only file system
ls -la /
drwxr-x— 1 root root 122 Jan 22 12:43 .snapshots
OK permissions set at 750 so Now
lsattr /.snapshots
-------------------- /mnt/mj/.snapshots/1

So no attributes set.
I have removed my config file.
I do not have /.snapper folder mounted.
I have booted from another OS on my computer and mounted the root, and tried again but even this fails just the same.
Thanks you for any ideas?

Have you tried

sudo btrfs subvolume list /
sudo btrfs subvolume delete /.snapshots/1 // <-- listed subvolume


sudo snapper -c root list // <- root is the name of your config
sudo snapper -c root delete x-y // x-y a snapper snapshot number range

Thank you @Hagen that did the trick. I had to do this:
sudo btrfs subvolume delete /.snapshots/1/snapshot
and do each one manually. I had deleted the config file so could not do the quick one you suggested with snapper -c root delete x-y below.

maybe some

sudo rm -r /.snapshots

is needed afterwards

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.