Cannot print with cups-nosystemd Brother MFC-7460DN

I have tried socket://ip-address:9100, lpd://ip-address/queue and lpd://BRN001BA9896848/BINARY_P1 documents don’t print yet they’re moved to completed and no errors…

pacman -Qs cups
local/cups-filters 1.13.4-1
OpenPrinting CUPS Filters
local/cups-nosystemd 2.2.2-2
The CUPS Printing System - daemon package
local/cups-openrc 20170401-1 (openrc-misc)
OpenRC cups init script
local/cups-pdf 3.0.1-1
PDF printer for cups
local/libcups 2.2.3-1
The CUPS Printing System - client libraries and headers

You will need the driver from Brother, you have 2 option for this.

  1. Use the driver installer from brother:
    http://support.brother.com/g/b/downloadend.aspx?c=us_ot&lang=en&prod=mfc7460dn_all&os=128&dlid=dlf006893_000&flang=4&type3=625&dlang=true

  2. Use the AUR packages:
    https://aur.archlinux.org/packages/brother-mfc-7460dn/
    https://aur.archlinux.org/packages/brscan4
    https://aur.archlinux.org/packages/brscan-skey

NOTE: For option 1 you will need dpkg from the AUR installed first, rpm-org may also be an option here, but I haven’t tried it.

Thanks for your response. The drivers are already installed. I used the installer from the Brother site. Should I need to reinstall them? This has only been a problem since I changed to nosystemd, cups worked great.

I re-installed version 2.1 from the Brother site and setup a socket://ip-address:9100 printer and sent a test page which still did not print again. Below is what I find in the Completed Jobs section on the cups page.

ID	Name	User	Size	Pages	State	Control
MFC7460DN-14 	Unknown 	Withheld 	1k 	Unknown 	completed at
Sat 22 Apr 2017 04:49:38 PM CEST

I just discovered I was missing the lib32-glibc package as I heard lib32 was being deprecated and I deactivated multilib…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.