Cannot paste files from USB to mounted drive

Hello community, i have a problem:
Recently got Manjaro KDE installed in one of my SSD drives.
I have 3 drives, counting the main drive where the OS is installed
2 of them have been purposed as mass storage, all formatted as ext4.
I tried to copy some files from an USB i had some backup files saved, and tried to copy them, with no success, Dolphin file manager throws an error [ACCESS DENIED: could not write to /run/media/user/storage].
May be something regarding permissions?
I checked with KDE partition manager and cannot modify in any way, and there appears a lock, i don’t know if it should be that way:

Is there something i missed while configuring all of this?
Another shot where i checked the mounted device properties using Dolphin:

Your second screenshot shows root as the owner. We need to change that. This command for each new partition.
sudo chown username:username mountpoint

sudo gives root to the command

chown is a too to change ownership

username:username change both to match your username

mountpoint Path to the directory to which you are applying the ownership

To find the path, open a second terminal and run cd .. twice then cd media/ then run ls which should show your username, run cd username/ run ls again and now you should see the name of the partition(s) you need to chown.

The lock means you can’t modify it, because it’s mounted. :slight_smile:

As @TheHappyHobbit says you need to change ownership.

# $USER is an environment variable 
# which contains the current username
# so you don't have to change it
sudo chown $USER:$USER  /run/media/user/storage # or use a better mountpoint

However I suggest using a mountpoint in /media, rather than auto mounting via a file manager (if you’re already using fstab/systemd then don’t use /run). Read the links below for further information.

For a permanent mountpoint, I'd do this
sudo mkdir -p /media/storage
lsblk -f # Copy the UUID for the partition you want to mount

# Edit /etc/fstab and add the line below
# making sure to replace <uuid> with the UUID
UUID=<uuid> /media/storage ext4 defaults,relatime 0 2

# unmount the partition, if it's already mounted
sudo umount UUID=<uuid>

# Mount it using the fstab entry
sudo mount -a

# run lsblk to see if it worked

# if it's not mounted
# then post any errors and the contents of fstab
# don't reboot without first commenting out the bad entry
# by placing a # at the beginning of the line
# a bad fstab entry will cause issues during boot
Click here for some useful links


So start in /home/$USER then cd .. twice to /, then cd to /media which by default doesn’t exist. Why not just cd /media? It won’t work any better but it’s easier. :confused:

The OP has the drive mounted at /run/media/user/storage (presumably /run/media/$USER/storage) which can be seen by using a simple command such as lsblk -f (or reading their post :grin: ).

1 Like