Cannot manage to have a external monitor and laptop display working at the same time

This is not exactly true. AFAIK you need to set it up correctly. But…

  • What driver did you have installed at first?
  • What happened when you connected the external monitor with your old (driver) setup?
  • Did you search the forum for issues related to your specific card and nvidia?
  • Check what the Xorg.0.log reports on boot and with plugging ext monitor

I would suggest to start clean,

  • uninstall VGA driver with mhwd,
  • clean blacklists from /etc/modprobe.d/mhwd*
  • Reboot (before grub execution unplug external monitor)
  • If X fails
    • go to TTY and install bumblebee or plain nvidia (since you 'll have it on power as workstation)
    • Restart DM (ie. sudo systemctl restart lightdm)
  • Login and connect external monitor
  • If no Display Connect success or Popup , run xrandr to check if ext-mon is recognized

Then report any results to continue troubleshooting.

Disclaimer
Nvidia and bumblebee is a PITA, at least to me, so, proceed with care.

the external monitor is working with the nvidia driver but then the laptop monitor stops to update the display upon an error:

Failed to probe lspcon
LSPCOM init failed on por

The output from xrandr

Xorg.0.log seems oki

Xorg.8.log seems messed something with permissions from bumblebee.

What driver did you have installed at first?

Not sure but I retested all of them.

What happened when you connected the external monitor with your old (driver) setup?
Did you search the forum for issues related to your specific card and nvidia?

Yes

Check what the Xorg.0.log reports on boot and with plugging ext monitor

Just provided the log above and I believe it is related to bumblebee

image

I need to mirror my screen when I am in school. Sometimes it doesn’t work. So I start

arandr

(just like it was mentioned by @linux-aarhus) and then I activate the second monitor/beamer. Before I activate it, arandr just shows my laptop screen (eDPI)…

My quick guess is you have to blacklist nouveau.
Check for any conf files in the related folders

/etc/X11
/etc/X11/xorg.conf.d
/etc/bumblebee
/etc/bumblebee/xorg.conf.d

Report what you found, please.

Check for a blacklist in
/etc/modprobe.d
If there is no, create blacklist-nouveau.conf
with
blacklist nouveau
inside.

I will try the blacklist but I’ve also found this. Might them be related?

Also xrandr never displays both screens as you can see above.

That is pretty far from your issue. You have bothmonitors recognized at some point with the same kernel.
By your screenshots I assume you are on KDE, correct?
Have your laptop boot without external monitor.
Open your DE’s (KDE) Display Settings and connect the monitor to observe the behavior.
Anyway, at most you need to configure a proper xorg.conf to have a stable setup. Until now everything is done automatic, by default system procedures.

1 Like

Something is broken, manajro does not recognize the second output. Just checked:

lshw -C display
  *-display                 
       description: VGA compatible controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 04
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:126 memory:dd000000-ddffffff memory:b0000000-bfffffff ioport:f000(size=64) memory:c0000-dffff

The hdmi cable is not listed.

Pression F8 would turn the remote screen on but it reports no external screen avaliable as expected from lshw -C display

Oki seems I have a kernel issue and a missconfiguration, with kernel 4.9 the output is listed I just cannot enable it. More details here

@rexmalcolm what kernel do you use?

I suggest you boot from a live installer environment and check whether the display works correctly there. If so, it’s a local configuration issue.

I run 4.15. But I don’t have a Nvidia card. Just Intel Integrated Graphics Controller.

@jonathon I did boot from CD and tried to have it torecognized the external monitor with no luck, Using the nvidia driver I was able to have the external monitor working while the laptop screen hangs in black.
You commented on the list you have this setup working do you mind to please share the details?

@rexmalcolm so maybe I can select it as my primary card.

I installed with the non-free drivers (which installs bumblebee intel+nvidia). External displays work OOB.

I suggest you return to the same driver and then work out why the external display isn’t being enabled with that driver, rather than switching to different drivers in the hope something will work, then asking for help with what’s no longer a single problem.

See also: http://xyproblem.info/

1 Like

@jonathon I just came back to the non free drivers and I agree with you regarding focusing in a single solution still it has not worked oob for me. Hence let me ask again which kernel/drivers version are you using?

You haven’t asked me that at all yet.

I’m running kernel 4.15 with the NVIDIA 390.25 drivers. However, external displays have worked with every kernel and every driver I’ve used since I installed Manjaro several years ago. Hence, this is the wrong thing to be focussing on.

For example, do you have a keyboard button which switches display outputs? What options are there in your BIOS regarding display outputs? What does KDE’s display settings report? What’s the output of xrandr --prop?

Which ones, specifically? NVIDIA or intel-nvidia ?

Pressing F8 (the key to enable the external monitor) results in the lappy screen blinking and the image from no external output being displayed. There is no option on the bios regarding the external monitor usage.

The output from xrand --prop is:

xrandr --prop
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
eDP1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 340mm x 190mm
        EDID: 
                00ffffffffffff0006afed6300000000
                001b0104952213780259259358599329
                26505400000001010101010101010101
                010101010101783780b470382e406c30
                aa0058c11000001a602c80b470382e40
                6c30aa0058c11000001a000000fe0043
                56353646804231353648414e00000000
                0000410296001000000a010a202000a9
        BACKLIGHT: 7500 
                range: (0, 7500)
        Backlight: 7500 
                range: (0, 7500)
        scaling mode: Full aspect 
                supported: Full, Center, Full aspect
        Broadcast RGB: Automatic 
                supported: Automatic, Full, Limited 16:235
        audio: auto 
                supported: force-dvi, off, auto, on
        link-status: Good 
                supported: Good, Bad
   1920x1080     60.05*+  59.93    48.04  
   1680x1050     59.88  
   1400x1050     59.98  
   1600x900      60.00    59.95    59.82  
   1280x1024     60.02  
   1400x900      59.96    59.88  
   1280x960      60.00  
   1368x768      60.00    59.88    59.85  
   1280x800      59.81    59.91  
   1280x720      59.86    60.00    59.74  
   1024x768      60.00  
   1024x576      60.00    59.90    59.82  
   960x540       60.00    59.63    59.82  
   800x600       60.32    56.25  
   864x486       60.00    59.92    59.57  
   640x480       59.94  
   720x405       59.51    60.00    58.99  
   640x360       59.84    59.32    60.00  
DP1 disconnected (normal left inverted right x axis y axis)
        Broadcast RGB: Automatic 
                supported: Automatic, Full, Limited 16:235
        audio: auto 
                supported: force-dvi, off, auto, on
        link-status: Good 
                supported: Good, Bad
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

I`m using the hybrid intel nvidia bumblebee again

This would normally signify an external (Display Port) display; going from your logs above your internal panel should be DFP-1.

Can you confirm your current display state?

So, maybe it’s a feature of your laptop and not a bug?
Anyway, save this output (xrandr) with your EDID and display properties. You might need it if you give another shot to configuring Xorg.
Maybe you have to live with that and just find your practical way.
I would suggest to search for an answer from the manufacturer or/and try some forum(?) or web search with your exact model.

@jonathon Linux only displays on the notebook or externel monitor never both. I`m not a native english speaker so it you have extra doubts please ask as clear as possible. :slight_smile: and thanks for the help so far

@AgentS the output works in windows mirroring the screen so it is not a feature of the laptop it is some linux config.

Archwiki was always our friend.
Bumblebee - Multiple_monitors

1 Like

@AgentS yes that really looks like what I need. Still im confused about which file to edit does these configs belong to /etc/bumblebee/xorg.conf.nvidia or /etc/X11/xorg.conf.d/90-mhwd.confor /etc/X11/mhwd.d/intel.conf?
I tried

mhwd-gpu --status
:: status
xorg configuration file: ‘/etc/X11/mhwd.d/intel.conf’```

And added to intel.conf

####Teste####

Section "Screen"
Identifier "Screen1"
Device "intelgpu1"
Monitor "Monitor1"
DefaultDepth 24
Option “TwinView” "1"
SubSection "Display"
Depth 24
Modes "1920x1080_60.00"
EndSubSection
EndSection

Section "Monitor"
Identifier "Monitor1"
Option “Enable” "true"
EndSection

Section "Device"
Identifier "intelgpu0"
Driver "intel"
Option “XvMC” "true"
Option “UseEvents” "true"
Option “AccelMethod” "UXA"
BusID "PCI:0:2:0"
EndSection


Rebooted but the hdmi monitor still does not display. But arsnd shows a clone second screen so I must be close.

I just tried an ubuntu livecd and it works out of the box in the live media. So it is not my hardware fault. Question is what do I need to do in manjaro?

The livecd was using the nouveau driver. Trying to use it in manjaro resulted in a system hang.

Forum kindly sponsored by