Cannot load Manjaro cinnamon ISO in grub

Hello !
I tried your custom.config to boot last manjaro-cinnamon-21.07.iso
no success.
Complaining about squashfs to ram and abort.
If i remove copytoram, abort also but later.
So i searched and find this (adapted for me):

menuentry “Boot iso Manjaro 21.07” {
set iso_path="/mnt/ISO/manjaro-cinnamon-21.0.7-210623-linux510.iso"
search --set=root --file $iso_path
probe -u $root --set=iso_disk
set iso_device="/dev/disk/by-uuid/$iso_disk"
loopback loop $iso_path
echo ‘Lancement en cours, patientez …’
probe -l (loop) --set=klabel
linux (loop)/boot/vmlinuz-x86_64 img_dev=$iso_device img_loop=$iso_path misobasedir=manjaro misolabel=$klabel copytoram driver=nonfree lang=fr_FR keytable=fr tz=Europe/Paris
initrd (loop)/boot/amd_ucode.img (loop)/boot/initramfs-x86_64.img

This one works for me.
What it the difference between yours and this one, i am not an expert…

My example loads the iso to ram so it performs better and you can install also to the partition where the iso is located. You seem not to have enough ram for this

The Tutorial thread it for posting messages to improve the tutorial, not for requesting support, so this has been moved to the support category.


Thank you for your answer.
I have 32GB ram, so there is another reason.
I tried just for fun…no matter.