Cannot launch OpenShot video editor

Launching OpenShot results in the following error:

Loaded modules from: /usr/lib/python3.10/site-packages/openshot_qt
INFO app: ------------------------------------------------
INFO app:             Wed Apr 27 20:48:39 2022
INFO app:               Starting new session
ERROR app: OpenShotApp::Import Error
Traceback (most recent call last):
  File "/usr/lib/python3.10/site-packages/openshot_qt/classes/app.py", line 99, in __init__
    from classes import settings, project_data, updates
  File "/usr/lib/python3.10/site-packages/openshot_qt/classes/project_data.py", line 48, in <module>
    import openshot
  File "/usr/lib/python3.10/site-packages/openshot.py", line 15, in <module>
    import _openshot
ImportError: libx264.so.163: cannot open shared object file: No such file or directory
Traceback (most recent call last):
  File "/usr/bin/openshot-qt", line 33, in <module>
    sys.exit(load_entry_point('openshot-qt==2.6.1', 'gui_scripts', 'openshot-qt')())
  File "/usr/lib/python3.10/site-packages/openshot_qt/launch.py", line 186, in main
    app = OpenShotApp(argv)
  File "/usr/lib/python3.10/site-packages/openshot_qt/classes/app.py", line 99, in __init__
    from classes import settings, project_data, updates
  File "/usr/lib/python3.10/site-packages/openshot_qt/classes/project_data.py", line 48, in <module>
    import openshot
  File "/usr/lib/python3.10/site-packages/openshot.py", line 15, in <module>
    import _openshot
ImportError: libx264.so.163: cannot open shared object file: No such file or directory
INFO app:             OpenShot's session ended
INFO app:             Wed Apr 27 20:48:39 2022
INFO app: ================================================

Installed package 2.6.1-5 from official repos. Looking for libx264 I see:

/usr/lib/libx264.so
/usr/lib/libx264.so.164

Any suggestions?

I spot an update for libopenshot in unstable. It may bring a fix for this.


In the meantime: [HowTo] Update an application early to the latest version

did you update the python packages as suggested here:
also take care for the rebuild of aur-packages that are also recommended

This seems like the core issue.
So libopenshot was not rebuilt for the new libx264, so it’s still looking for the old one.
As @maycne.sonahoz mentioned above, the rebuild to libopenshot just got into unstable.

I don’t think this has anything to do with python packages.