Cannot install oracle-sqldeveloper, help to follow instructions

Hi there,

I’m trying to install AUR (en) - oracle-sqldeveloper for work (SQL training I have no experience with).

It does not work by using manjaro’s add/remove program.

I am trying to follow the instructions in the pinned comment but it does not seem to work. Could someone please spell it out for me what to do?

I tried copying and pasting PKGBUILD in mousepad and placing it into an empty folder, and also installed the no-jre zip they were talking about, but it did not work as suggested in the comment with makepkg.

Thanks in advance for any support given,

1- download and extract the snapshot to a folder. from AUR (en) - oracle-sqldeveloper
2 Just as the comment said, download from "Other Platforms" the .zip file on this page Oracle SQL Developer Downloads
3- Place the .zip file in the same folder as the extracted snapshot ( It is unclear if that needs to be unzipped)
4-in terminal change to the folder where you extracted the snapshot
5-call makepkg in terminal:
makepkg -cs --skipchecksums or makpkg -csi --skipchecksums (If you prefer to have the PKGBUILD verify the checksums, then you will have to obtain said checksums from Oracle website where you downloaded the .zip file. They look okay to me so you can try makepkg -cs and see how it goes.

I have not tried the above to test as there are way too many dependencies involved.

1 Like

Thank you so much for your help.

I’m almost there. The only problem now is that oracle won’t run because:
Default JDK not found Type the full pathname of a JDK installation (or Ctrl-C to quit), the path will be stored in /home/scott/.sqldeveloper/20.4.1/product.conf
I believe I do have jdk installed. How do I find the path for it?

As far as I know sqldeveloper won’t run with Java 15, so it’ll be /usr/lib/jvm/java-8-openjdk.

Yes! it works. Thank you so much.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.