Cannot install Manjaro to a specific partition

Just tried for quite a while to install Manjaro but there was NO way Manjaro would allow me to install anything without wiping out everything first! All the help I could find about installing to partitions was about dual-booting which I do NOT want!!

So, I have a hard drive partitioned into 2 sections, one is W10, the other is data. All Manjaro would allow is a total wipeout of the entire disk, or when I chose replace it still left a 500mb partition for windows boot loader?! When i ran a windows install to remove the windows partition then format it to a basic partition, the Manjaro installer then removed the Replace option…so that didn’t work either.

So I thought I’d try manual, so I set the partition as Fat 32 (as instructed) set mount to /EFI/Boot (I’ve probs got the syntax wrong there, but it was the exact syntax when I was trying it) as instructed set the boot flag to on as instructed - nothing, the next tab resolutely stayed grey…again the only way I could go forward was to wipe the entire disk or wasted half a gig of space for something I don’t want/need.

Obviously doing something wrong but I cannot figure it, so any ideas on how I can achieve this would be welcome.

can you boot on USb iso manjaro
open a terminal and a browser on this topic
and returns

inxi -Fza
sudo parted -l
sudo efibootmgr -v

When you plan to install Manjaro and don’t want to wipe your WIN10 then this is dual-booting!

No, please read what I wrote…I do NOT want dual booting! I actually want to WIPE the windows partition, BUT the Manjaro installer will not allow this and l;eave my current Data partition in place!

Thanks for the ipt, but I am unsure what you mean? I am trying to install from a Manjaro installer, I do not have a terminal program available.

ok, what I decided to do is copy all the personal work data to a totally separate drive, so now I can essentially just use the whole drive. So I would ask for the steps to do this…I have read about 10 different responses in google and it all just gets so confusing!

So, at the moment, in Windows I have a “Programs” partition which runs W10 itself and all the programs i need/want to install, on this same drive is the Data partition which is, well, all my data and this does not get touched when re-installing the OS. I would like the same in linux.

I know this can be done at install with the Manjaro installer, but I’d like to ask the correct method and syntax, correct “file-system” , recommended sizes (not necessarily for data as i want that as large as possible. i was thinking maybe a 200/300 gb split? where 200 is for programs and OS in linux and the 300 being the separate partition with the /home folder on it.

I hope I have explained that well enough??


Are you by any chance able to back up that Data partition elsewhere temporarily? Reason why I am asking is because it would be best to reformat the partition table to GPT, but doing so would also wipe out the whole drive. You’re probably using a MBR BIOS partition table atm.

NVM, you answered my question haha. You should go to manual partition, on the top, there should be an option to Create new partition table, and select GPT

For me personally,

I just do:

  • 100MB, fat32, /boot/efi
  • The rest of the SSD/HDD, ext4, /

If you want a /home partition, it’s up to you how big you want it. I don’t use a separate /home partition because all of my data / files are on a different partition and SSD. And I back up some config files myself (to GitLab).

meant to quote…

Cool thanks for the tips…one thing though, is it ok to make the boot/efi EXT4?

EDIT: I have tried to install without this boot but the installer will not let me proceed without it. I was happy to have Manjaro installed to Root, and then the /home partition but apparently i MUST have this boot sector of about 200mb

I am not sure.

Yes, you have to have a /boot/efi partition to be able to use a bootloader (though Arch just uses /boot)

That’s strange. But to be fair, I don’t use Calamares, I only install via Architect. You are mounting to /boot/efi NOT /boot right? They aren’t the same.

Yes /boot/efi

ok, seems that a consensus (of online research) seems to lead to this small /boot/efi being fat32 that’s what I’ll do. Doesn’t make sense though, I mean the rest is all ext4, so why it NEEDS to be Fat32 is beyond me hahaha!

Maximum compatibility for UEFI

From second link:

UEFI systems can access GPT disks and boot directly from them, which allows Linux to use UEFI boot methods. Booting Linux from GPT disks on UEFI systems involves creation of an EFI system partition (ESP), which contains UEFI applications such as bootloaders, operating system kernels, and utility software. Such a setup is usually referred to as UEFI-GPT , while ESP is recommended to be at least 512 MiB in size and formatted with a FAT32 filesystem for maximum compatibility.