Cannot install latest VSCode

SOLVED: I just solved the issue, pamac wasn’t updating the AUR packages for some reason, I installed yay and run yay -Syua and it updated the package correctly.

Hi everyone! I’m quite new using Manjaro, and it’s my first rolling release OS.

The problem is that I have two Manjaro installations in different computers. In my laptop I have the latest VSCode installed through AUR: visual-studio-code-bin 1.49.3-1, but on my desktop PC, running the latest stable kernel, just updated everything, but the package I have is visual-studio-code-bin 1.46.0-1.

I’m completely lost with what’s going on, how can I have such an old version in this PC? I tried updating everything but VSCode won’t update.


As packages build using AUR are unsupported you will need to be explicitly tell Pamac to rebuild the packages.

A version of VS Code is available in the official repo (Arch inherited) and the version in the repo is not the exact same version as the official - especially some Microsoft specials has been left out and the electron framework has been separated into it’s own package.

1 Like

:+1: Thank you for sharing back with the community! :+1:

Could you do me a favour and split your post into a question and an answer and then please mark a solution like this:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.


P.S. Once you do, I will remove this notice.