Cannot install dia (diagram editor)

I have tried aur/dia and it fails to compile with this message:

custom_object.c:923:28: warning: comparison between 'LineStyle' and 'enum DiaSvgLineDefaults' [-Wenum-compare]
  923 |   if ((el->any.s.linestyle == DIA_SVG_LINESTYLE_DEFAULT &&
      |                            ^~
custom_object.c:925:40: warning: comparison between 'LineStyle' and 'enum DiaSvgLineDefaults' [-Wenum-compare]
  925 |     (*cur_style) = (el->any.s.linestyle!=DIA_SVG_LINESTYLE_DEFAULT) ?
      |                                        ^~
make[3]: *** [Makefile:521: custom_object.lo] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: Leaving directory '/home/gandalf/.cache/yay/dia/src/dia-0.97.3/objects/custom'
make[2]: *** [Makefile:429: all-recursive] Error 1
make[2]: Leaving directory '/home/gandalf/.cache/yay/dia/src/dia-0.97.3/objects'
make[1]: *** [Makefile:602: all-recursive] Error 1
make[1]: Leaving directory '/home/gandalf/.cache/yay/dia/src/dia-0.97.3'
make: *** [Makefile:468: all] Error 2

Also tried aur/dia-git and it stops at this command:

Cloning into bare repository '/home/gandalf/.cache/yay/dia-git/dia'...

I have lots of dia files, and I need them for my work. Interestingly, I have another laptop with manjaro-i3 where dia is installed (although it was installed some months ago)

inxi
CPU: 12-core AMD Ryzen 9 3900X (-MT MCP-) speed/min/max: 2411/2200/4672 MHz
Kernel: 6.9.2-1-MANJARO x86_64 Up: 2h 50m Mem: 23.18/31.25 GiB (74.2%)
Storage: 9.76 TiB (1.1% used) Procs: 626 Shell: Bash inxi: 3.3.34

AUR (en) - dia

there are, perhaps helpful, comments.
Or try using makepkg?

It seems to be unmaintained. The comments say that aur/dia requires python2 and it fails to compile. They suggest to use dia-git but it cannot be cloned. I have been using dia for many years, I’m not sure what to do. I have hundreds of dia files that I must be able to open. :frowning:

The AUR is usually the last resort, however:

pamac build dia-git

Check its AUR page:

Last updated: 2024-05-11

Edit:- It seems to be building fine as I type…
Completed without issue. Cheers.

1 Like

Unfortunately, “pamac build dia-git” also hangs at the same step.

Cloning into bare repository '/var/tmp/pamac-build-gandalf/dia-git/dia'...

It might be a network issue. This is strange because my internet connection seems to be fine. Everything works except this.

Then the issue is with your environment. It completed successfully here.
Perhaps you’re missing a prerequisite of some kind.

See the Arch User Repository page in the Manjaro Wiki. See if you missed anything.

Cheers.

yay -S dia-git builds just fine. :man_shrugging:
And the resulting program works as well. :open_mouth:

I build Dia a few months ago for myself and still have the pkg file, I can send it if you are ready to trust me.

That’s good to know. I only tested the build.
I have a VM specially set aside for that (no GUI). :wink:

I have several, one for each flavor (Gnome, Plasma, Xfce, Cinnamon) and EOS as well.
Just so I can test and have a real live reference.
It’s a strange hobby, I know. :nerd_face:

The real hardware runs Mint.

All right, I have digged up the exact command that is hanging up.

 git clone --origin=origin --mirror https://gitlab.gnome.org/GNOME/dia.git /home/gandalf/.cache/yay/dia-git/dia

And then some tests:

# ping -c 1 gitlab.gnome.org
PING ocp-ingress.fastly.gnome.org (151.101.1.91) 56(84) bytes of data.
64 bytes from 151.101.1.91: icmp_seq=1 ttl=58 time=20.8 ms

# nc -vz -w 2 gitlab.gnome.org 443
gitlab.gnome.org [151.101.129.91] 443 (https) open

It seems to be available. I can ping it, and tcp/443 is open, but the “git clone” command never returns.

I don’t think that this is a missing prerequisity.

I have turned off my primary internet connection and switched to mobile network; then the git clone command succeeded and now it is building. I’m sorry, looks like this was a network problem after all. I have never seen anything like this before. ping and TCP connect works, there are no errors to any other hosts. Very strange.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.