Cannot install Corebird, Pale moon from AUR


#1

About a week ago when I first try Manjaro, I can install and use Corebird. Then I need to reinstall Manjaro but when I tried to install Corebird again it’s Error.
This is log

Build started at 2018-04-28T17:39:59.926071
Main binary: /usr/bin/python
Python system: Linux
The Meson build system
Version: 0.45.1
Source dir: /tmp/pamac-build-taman/corebird-git/src/corebird-git
Build dir: /tmp/pamac-build-taman/corebird-git/src/corebird-git/builddir
Build type: native build
WARNING: Unknown command line options: "SPELLCHECK, VIDEO"
This will become a hard error in a future Meson release.
Project name: Corebird
Sanity testing C compiler: cc
Is cross compiler: False.
Sanity check compiler command line: cc /tmp/pamac-build-taman/corebird-git/src/corebird-git/builddir/meson-private/sanitycheckc.c -o /tmp/pamac-build-taman/corebird-git/src/corebird-git/builddir/meson-private/sanitycheckc.exe
Sanity check compile stdout:

-----
Sanity check compile stderr:

-----
Running test binary command: /tmp/pamac-build-taman/corebird-git/src/corebird-git/builddir/meson-private/sanitycheckc.exe
Native C compiler: cc (gcc 7.3.1 "cc (GCC) 7.3.1 20180312")
Appending CFLAGS from environment: '-march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt'
Appending LDFLAGS from environment: '-Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now'
Appending CPPFLAGS from environment: '-D_FORTIFY_SOURCE=2'
Running compile:
Working directory:  /tmp/tmp3xx9dxqu
Command line:  valac /tmp/tmp3xx9dxqu/testfile.vala -C -C -o /tmp/tmp3xx9dxqu/output.obj 

Code:
 class MesonSanityCheck : Object { }
Compiler stdout:
 Compilation succeeded - 1 warning(s)

Compiler stderr:
 warning: --output and -o have no effect when -C or --ccode is set

Native Vala compiler: valac (valac 0.40.3)
Appending LDFLAGS from environment: '-Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now'
Build machine cpu family: x86_64
Build machine cpu: x86_64
Found pkg-config: /usr/bin/pkg-config (0.29.2)
Determining dependency 'glib-2.0' with pkg-config executable '/usr/bin/pkg-config'
Native dependency glib-2.0 found: YES 2.56.1
Determining dependency 'gtk+-4.0' with pkg-config executable '/usr/bin/pkg-config'

meson.build:17:0: ERROR: Native dependency 'gtk+-4.0' not found

I’ve no idea what is “gtk±4.0” when I tried to search it, nothing shows up.
Anyone can tell me why I cannot install this time? How to fix this error?

For Pale moon
This is what happen when I install Pale moon 27.9 from AUR

ld-taman/gcc5/src/gcc-build/prev-x86_64-pc-linux-gnu/libstdc++-v3/include  -I/tmp/pamac-build-taman/gcc5/src/gcc-5.5.0/libstdc++-v3/libsupc++ -L/tmp/pamac-build-taman/gcc5/src/gcc-build/prev-x86_64-pc-linux-gnu/libstdc++-v3/src/.libs -L/tmp/pamac-build-taman/gcc5/src/gcc-build/prev-x86_64-pc-linux-gnu/libstdc++-v3/libsupc++/.libs -c   -g -O2 -gtoggle -DIN_GCC    -fno-exceptions -fno-rtti -fasynchronous-unwind-tables -W -Wall -Wno-narrowing -Wwrite-strings -Wcast-qual -Wmissing-format-attribute -Woverloaded-virtual -pedantic -Wno-long-long -Wno-variadic-macros -Wno-overlength-strings   -DHAVE_CONFIG_H -DGENERATOR_FILE -I. -Ibuild -I/tmp/pamac-build-taman/gcc5/src/gcc-5.5.0/gcc -I/tmp/pamac-build-taman/gcc5/src/gcc-5.5.0/gcc/build -I/tmp/pamac-build-taman/gcc5/src/gcc-5.5.0/gcc/../include  -I/tmp/pamac-build-taman/gcc5/src/gcc-5.5.0/gcc/../libcpp/include -D_FORTIFY_SOURCE=2 \
	-o build/genattrtab.o /tmp/pamac-build-taman/gcc5/src/gcc-5.5.0/gcc/genattrtab.c
/tmp/pamac-build-taman/gcc5/src/gcc-build/./prev-gcc/xg++ -B/tmp/pamac-build-taman/gcc5/src/gcc-build/./prev-gcc/ -B/usr/x86_64-pc-linux-gnu/bin/ -nostdinc++ -B/tmp/pamac-build-taman/gcc5/src/gcc-build/prev-x86_64-pc-linux-gnu/libstdc++-v3/src/.libs -B/tmp/pamac-build-taman/gcc5/src/gcc-build/prev-x86_64-pc-linux-gnu/libstdc++-v3/libsupc++/.libs  -I/tmp/pamac-build-taman/gcc5/src/gcc-build/prev-x86_64-pc-linux-gnu/libstdc++-v3/include/x86_64-pc-linux-gnu  -I/tmp/pamac-build-taman/gcc5/src/gcc-build/prev-x86_64-pc-linux-gnu/libstdc++-v3/include  -I/tmp/pamac-build-taman/gcc5/src/gcc-5.5.0/libstdc++-v3/libsupc++ -L/tmp/pamac-build-taman/gcc5/src/gcc-build/prev-x86_64-pc-linux-gnu/libstdc++-v3/src/.libs -L/tmp/pamac-build-taman/gcc5/src/gcc-build/prev-x86_64-pc-linux-gnu/libstdc++-v3/libsupc++/.libs   -g -O2 -gtoggle -DIN_GCC    -fno-exceptions -fno-rtti -fasynchronous-unwind-tables -W -Wall -Wno-narrowing -Wwrite-strings -Wcast-qual -Wmissing-format-attribute -Woverloaded-virtual -pedantic -Wno-long-long -Wno-variadic-macros -Wno-overlength-strings   -DHAVE_CONFIG_H -DGENERATOR_FILE -static-libstdc++ -static-libgcc  -o build/genattrtab \
    build/genattrtab.o build/rtl.o build/read-rtl.o build/ggc-none.o build/vec.o build/min-insn-modes.o build/gensupport.o build/print-rtl.o build/read-md.o build/errors.o .././libiberty/libiberty.a
build/genattrtab /tmp/pamac-build-taman/gcc5/src/gcc-5.5.0/gcc/common.md /tmp/pamac-build-taman/gcc5/src/gcc-5.5.0/gcc/config/i386/i386.md insn-conditions.md \
	-Atmp-attrtab.c -Dtmp-dfatab.c -Ltmp-latencytab.c
/bin/sh /tmp/pamac-build-taman/gcc5/src/gcc-5.5.0/gcc/../move-if-change tmp-attrtab.c    insn-attrtab.c
/bin/sh /tmp/pamac-build-taman/gcc5/src/gcc-5.5.0/gcc/../move-if-change tmp-dfatab.c     insn-dfatab.c
/bin/sh /tmp/pamac-build-taman/gcc5/src/gcc-5.5.0/gcc/../move-if-change tmp-latencytab.c insn-latencytab.c
echo timestamp > s-attrtab
/tmp/pamac-build-taman/gcc5/src/gcc-build/./prev-gcc/xg++ -B/tmp/pamac-build-taman/gcc5/src/gcc-build/./prev-gcc/ -B/usr/x86_64-pc-linux-gnu/bin/ -nostdinc++ -B/tmp/pamac-build-taman/gcc5/src/gcc-build/prev-x86_64-pc-linux-gnu/libstdc++-v3/src/.libs -B/tmp/pamac-build-taman/gcc5/src/gcc-build/prev-x86_64-pc-linux-gnu/libstdc++-v3/libsupc++/.libs  -I/tmp/pamac-build-taman/gcc5/src/gcc-build/prev-x86_64-pc-linux-gnu/libstdc++-v3/include/x86_64-pc-linux-gnu  -I/tmp/pamac-build-taman/gcc5/src/gcc-build/prev-x86_64-pc-linux-gnu/libstdc++-v3/include  -I/tmp/pamac-build-taman/gcc5/src/gcc-5.5.0/libstdc++-v3/libsupc++ -L/tmp/pamac-build-taman/gcc5/src/gcc-build/prev-x86_64-pc-linux-gnu/libstdc++-v3/src/.libs -L/tmp/pamac-build-taman/gcc5/src/gcc-build/prev-x86_64-pc-linux-gnu/libstdc++-v3/libsupc++/.libs -c   -g -O2 -gtoggle -DIN_GCC    -fno-exceptions -fno-rtti -fasynchronous-unwind-tables -W -Wall -Wno-narrowing -Wwrite-strings -Wcast-qual -Wmissing-format-attribute -Woverloaded-virtual -pedantic -Wno-long-long -Wno-variadic-macros -Wno-overlength-strings   -DHAVE_CONFIG_H -I. -I. -I/tmp/pamac-build-taman/gcc5/src/gcc-5.5.0/gcc -I/tmp/pamac-build-taman/gcc5/src/gcc-5.5.0/gcc/. -I/tmp/pamac-build-taman/gcc5/src/gcc-5.5.0/gcc/../include -I/tmp/pamac-build-taman/gcc5/src/gcc-5.5.0/gcc/../libcpp/include  -I/tmp/pamac-build-taman/gcc5/src/gcc-5.5.0/gcc/../libdecnumber -I/tmp/pamac-build-taman/gcc5/src/gcc-5.5.0/gcc/../libdecnumber/bid -I../libdecnumber -I/tmp/pamac-build-taman/gcc5/src/gcc-5.5.0/gcc/../libbacktrace -I/tmp/pamac-build-taman/gcc5/src/gcc-build/./isl/include -I/tmp/pamac-build-taman/gcc5/src/gcc-5.5.0/isl/include -D_FORTIFY_SOURCE=2 -o insn-attrtab.o -MT insn-attrtab.o -MMD -MP -MF ./.deps/insn-attrtab.TPo insn-attrtab.c
/tmp/pamac-build-taman/gcc5/src/gcc-build/./prev-gcc/xg++ -B/tmp/pamac-build-taman/gcc5/src/gcc-build/./prev-gcc/ -B/usr/x86_64-pc-linux-gnu/bin/ -nostdinc++ -B/tmp/pamac-build-taman/gcc5/src/gcc-build/prev-x86_64-pc-linux-gnu/libstdc++-v3/src/.libs -B/tmp/pamac-build-taman/gcc5/src/gcc-build/prev-x86_64-pc-linux-gnu/libstdc++-v3/libsupc++/.libs  -I/tmp/pamac-build-taman/gcc5/src/gcc-build/prev-x86_64-pc-linux-gnu/libstdc++-v3/include/x86_64-pc-linux-gnu  -I/tmp/pamac-build-taman/gcc5/src/gcc-build/prev-x86_64-pc-linux-gnu/libstdc++-v3/include  -I/tmp/pamac-build-taman/gcc5/src/gcc-5.5.0/libstdc++-v3/libsupc++ -L/tmp/pamac-build-taman/gcc5/src/gcc-build/prev-x86_64-pc-linux-gnu/libstdc++-v3/src/.libs -L/tmp/pamac-build-taman/gcc5/src/gcc-build/prev-x86_64-pc-linux-gnu/libstdc++-v3/libsupc++/.libs -c   -g -O2 -gtoggle -DIN_GCC    -fno-exceptions -fno-rtti -fasynchronous-unwind-tables -W -Wall -Wno-narrowing -Wwrite-strings -Wcast-qual -Wmissing-format-attribute -Woverloaded-virtual -pedantic -Wno-long-long -Wno-variadic-macros -Wno-overlength-strings   -DHAVE_CONFIG_H -DGENERATOR_FILE -I. -Ibuild -I/tmp/pamac-build-taman/gcc5/src/gcc-5.5.0/gcc -I/tmp/pamac-build-taman/gcc5/src/gcc-5.5.0/gcc/build -I/tmp/pamac-build-taman/gcc5/src/gcc-5.5.0/gcc/../include  -I/tmp/pamac-build-taman/gcc5/src/gcc-5.5.0/gcc/../libcpp/include -D_FORTIFY_SOURCE=2 \
	-o build/genautomata.o /tmp/pamac-build-taman/gcc5/src/gcc-5.5.0/gcc/genautomata.c
/tmp/pamac-build-taman/gcc5/src/gcc-build/./prev-gcc/xg++ -B/tmp/pamac-build-taman/gcc5/src/gcc-build/./prev-gcc/ -B/usr/x86_64-pc-linux-gnu/bin/ -nostdinc++ -B/tmp/pamac-build-taman/gcc5/src/gcc-build/prev-x86_64-pc-linux-gnu/libstdc++-v3/src/.libs -B/tmp/pamac-build-taman/gcc5/src/gcc-build/prev-x86_64-pc-linux-gnu/libstdc++-v3/libsupc++/.libs  -I/tmp/pamac-build-taman/gcc5/src/gcc-build/prev-x86_64-pc-linux-gnu/libstdc++-v3/include/x86_64-pc-linux-gnu  -I/tmp/pamac-build-taman/gcc5/src/gcc-build/prev-x86_64-pc-linux-gnu/libstdc++-v3/include  -I/tmp/pamac-build-taman/gcc5/src/gcc-5.5.0/libstdc++-v3/libsupc++ -L/tmp/pamac-build-taman/gcc5/src/gcc-build/prev-x86_64-pc-linux-gnu/libstdc++-v3/src/.libs -L/tmp/pamac-build-taman/gcc5/src/gcc-build/prev-x86_64-pc-linux-gnu/libstdc++-v3/libsupc++/.libs   -g -O2 -gtoggle -DIN_GCC    -fno-exceptions -fno-rtti -fasynchronous-unwind-tables -W -Wall -Wno-narrowing -Wwrite-strings -Wcast-qual -Wmissing-format-attribute -Woverloaded-virtual -pedantic -Wno-long-long -Wno-variadic-macros -Wno-overlength-strings   -DHAVE_CONFIG_H -DGENERATOR_FILE -static-libstdc++ -static-libgcc  -o build/genautomata \
    build/genautomata.o build/rtl.o build/read-rtl.o build/ggc-none.o build/vec.o build/min-insn-modes.o build/gensupport.o build/print-rtl.o build/read-md.o build/errors.o .././libiberty/libiberty.a -lm
build/genautomata /tmp/pamac-build-taman/gcc5/src/gcc-5.5.0/gcc/common.md /tmp/pamac-build-taman/gcc5/src/gcc-5.5.0/gcc/config/i386/i386.md \
  insn-conditions.md > tmp-automata.c
make[3]: *** [Makefile:2139: s-automata] Error 1
make[3]: Leaving directory '/tmp/pamac-build-taman/gcc5/src/gcc-build/gcc'
make[2]: *** [Makefile:4414: all-stage2-gcc] Error 2
make[2]: Leaving directory '/tmp/pamac-build-taman/gcc5/src/gcc-build'
make[1]: *** [Makefile:23022: stage2-bubble] Error 2
make[1]: Leaving directory '/tmp/pamac-build-taman/gcc5/src/gcc-build'
make: *** [Makefile:905: all] Error 2
==> ERROR: A failure occurred in build().
    Aborting...


#2

It is actually failing to built gcc5 which is required by palemoon

Install palemoon-bin from Manjaro repos

You are trying to install corebird-git not corebird

Corebird (stable) have been moved from the AUR to the Arch official repo and has reached Manjaro stable repo with the latest update, use that


#3

Thank you, sorry for a silly question but How to do that?

So, I can only use this version for now right?


#4

Update the pacman db first, if necessary the mirror list also

This is the update [Stable Update] 2018-04-28 - Kernels, Cinnamon, Browsers, Mesa, KDE Apps, KDE Framework, Virtualbox

Yes, until the gcc5 compiling issue isn’t fixed

Using that binary version will save you a lot of time and resources


#5

By these steps right?
https://wiki.manjaro.org/index.php?title=Pacman_Tips


#6

Yes, but you can also do that from the package manager, update db is in the menu, the mirror list is in menu->preferences->official repository


#7

Thank you so much. I can install them now :slight_smile:


#8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.