Cannot get netgear ac6100 usb wifi to work


#1

Hi everyone,

I am new to Manjaro and love it. Running Gnome trying to get this driver to work. It uses the rtl8811au driver. I tried to install that through AUR and it installed but I dont see my device and its not working. Any advise would be great, as I am completely lost.
Here is my outpit for inxi -Fx:
Network: Card-1: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
driver: r8168 v: 8.045.08-NAPI port: f000 bus-ID: 28:00.0
IF: enp40s0 state: down mac: 88:d7:f6:c4:fd:37
Card-2: Belkin F7D1101 v1 Basic Wireless Adapter [Realtek RTL8188SU]
usb-ID: 001-029
IF: N/A state: N/A mac: N/A

My belkin shows up and works out of the box.
lsusb does show it:
[fsociety@fsociety ~]$ lsusb
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 17ef:6019 Lenovo
Bus 003 Device 002: ID 04b3:3025 IBM Corp. NetVista Full Width Keyboard
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 029: ID 050d:945a Belkin Components F7D1101 v1 Basic Wireless Adapter [Realtek RTL8188SU]
Bus 001 Device 033: ID 0846:9052 NetGear, Inc. A6100 AC600 DB Wireless Adapter [Realtek RTL8811AU]
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Any advise would be great.


#2

I think you have a few things you need to check first. Are you on kernel 4.15, if so I believe your drivers are currently broken with the new kernel. If you are on the newest kernel version then your choice is to downgrade to 4.14, or wait for the new kernel patches to arrive. I believe they are in testing now.

The other thing is I don’t believe your drivers are natively supported in the kernel. You need to install the linux-headers package (AUR) for your kernel, then reboot. Then you need to install the dkms drivers from the AUR for your wifi model, and reboot again. I believe the drivers you’re looking for are (includes rtl8811AU) :

rtl8821au-dkms-git

https://aur.archlinux.org/packages/rtl8821au-dkms-git/

You may get more response by editing the title of your post to reflect your driver, rather than the retail card makers brand number.Also, there have been other posts about the rtl8811/12 driver issues recently. A forum search will turn up more detailed info on your drivers and their issues.


Wifi NetworkManager toggles between on and off
#3

Thanks for the response

I did what you said and installed the linux-headers package. I have the Linux Kernel 4.14.1 and had the driver installed. It worked great. after a reboot and unplug and replug.


#4

Awesome, glad I could help.


#5

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.