Cannot get grub menu to show up on boot

I have edited my grub config under/etc/default/grub in and ran sudo update-grub but the menu still does not show up on boot. I have also tried pressing space and or caps lock on boot with no luck.
Running a Lenovo W550s.

GRUB_DEFAULT=saved
GRUB_TIMEOUT=5
GRUB_TIMEOUT_STYLE=menu
GRUB_DISTRIBUTOR="Manjaro"
GRUB_CMDLINE_LINUX_DEFAULT="apparmor=1 security=apparmor udev.log_priority=3"
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
#GRUB_SAVEDEFAULT="true"

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment this option to enable os-prober execution in the grub-mkconfig command
GRUB_DISABLE_OS_PROBER=false

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/usr/share/grub/background.png"
GRUB_THEME="/usr/share/grub/themes/manjaro/theme.txt"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to ensure that the root filesystem is mounted read-only so that
# systemd-fsck can run the check automatically. We use 'fsck' by default, which
# needs 'rw' as boot parameter, to avoid delay in boot-time. 'fsck' needs to be
# removed from 'mkinitcpio.conf' to make 'systemd-fsck' work.
# See also Arch-Wiki: https://wiki.archlinux.org/index.php/Fsck#Boot_time_checking
#GRUB_ROOT_FS_RO=true

Welcome to the forum!

Is it only the menu that doesn’t show up, or does the machine refuse to boot into Manjaro? If the former, then it might be an issue with the graphics resolution.

Booting OK, though when I do spam space and caps it appears to take considerably longer.

Either hold Shift or tap Esc.

Held left shift through all of boot and it blew right past it. Esc overlaps with bios. Could try to time it though I have not had success

First make sure you are using grub from Manjaro, not using other boot manager or grub from another distro. You can install grub to disk with grub-install.

1 Like

… from within Manjaro ─ not from within any other distribution on your computer. Manjaro’s GRUB needs to be in control.

1 Like

Ran sudo grub-install for the drive. Ran without error. Appears to use the same config given it is not quiet booting as I removed that flag in the config above. So it appear to be using the config, just ignoring the menu flag somehow.

I did follow a guide a month or so ago to get BTRFS snapshots to show up on the boot menu, but I am not getting errors with the sudo update-grub command.