Cannot get expected resolution on external monitor

I have an HP EliteBook 840 G2 laptop, running dual boot Manjaro i3 and Win10. I want to use this laptop with an external 24" Philips 244E monitor. Under Win10 connecting the DisplayPort cable to the monitor gives me the correct 1920x1080 resolution on that external monitor. The Fn+F4 key to switch displays works fine under Win10.

However under latest Manjaro i3WM edition the Fn+F4 key does not work and the system default resolution to the external monitor is only 1280x720, even after a reboot. I can force the resolution to 1920x1080 using:

"xrandr --output HDMI1 --mode 1920x1080:

however, when I do that a large portion of the screen on the external monitor is unused, better res. of course but there are black unused sections below and to the right of the image ???

Any ideas on how to proceed would be appreciated…

Probably because there isn’t running anything to handle it, i3 won’t do it.

Have you tried arandr for setting the resolution and position of the displays?

Yes, I have just tried “arandr” but still get same result with black unused border below and to right.

OK. Figured it out: this is an ignorance on my part of how i3 deals with 2 monitors. This works for me:

“xrandr --output HDMI1 --auto --right-of eDP1”

I will put that to a hot key in my i3 config file somewhere.

1 Like