Cannot force dGPU usage in Steam/Proton

Hi! I’ve been using primarily Debian based distros for a while and I just pulled the trigger on diving into Manjaro with my new laptop. I experienced a 140 → 30 FPS drop in Rocket League vs. windows on the same computer. Per radeontop, it appears my dedicated GPU is sitting idle, with the iGPU pulling all the weight. I tried mucking about with the drivers as well as some flags (DRI_PRIME, dxvk filter) to no avail, except with DRI_PRIME=1 glxinfo.

I’m not really sure where to go from here :confused:

Selected commands & outputs:

inxi -F

System:    Host: dump Kernel: 5.11.1-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.21.3 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: G5 5505 v: 1.5.0 serial: <superuser required> 
           Mobo: Dell model: 0JT83K v: A02 serial: <superuser required> UEFI: Dell v: 1.5.0 date: 10/27/2020 
CPU:       Info: 8-Core model: AMD Ryzen 7 4800H with Radeon Graphics bits: 64 type: MT MCP cache: L2: 4 MiB 
           Speed: 1397 MHz min/max: 1400/2900 MHz Core speeds (MHz): 1: 1397 2: 1397 3: 1397 4: 1397 5: 1397 6: 1397 7: 1397 
           8: 1397 9: 1403 10: 1628 11: 1425 12: 1397 13: 1397 14: 1397 15: 1397 16: 1397 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT] driver: amdgpu 
           v: kernel 
           Device-2: Advanced Micro Devices [AMD/ATI] Renoir driver: amdgpu v: kernel 
           Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo 
           Display: x11 server: X.Org 1.20.10 driver: loaded: amdgpu,ati unloaded: modesetting,radeon 
           resolution: 1920x1080~144Hz 
           OpenGL: renderer: AMD RENOIR (DRM 3.40.0 5.11.1-1-MANJARO LLVM 11.1.0) v: 4.6 Mesa 20.3.4 

vulkaninfo | grep ‘^GPU id’

ERROR: [Loader Message] Code 0 : /usr/lib32/libvulkan_radeon.so: wrong ELF class: ELFCLASS32
ERROR: [Loader Message] Code 0 : /usr/lib32/libvulkan_intel.so: wrong ELF class: ELFCLASS32
GPU id : 0 (AMD RADV RENOIR (ACO)):
GPU id : 1 (AMD RADV NAVI10 (ACO)):

glxinfo | grep ‘OpenGL renderer’

OpenGL renderer string: AMD RENOIR (DRM 3.40.0, 5.11.1-1-MANJARO, LLVM 11.1.0)

DRI_PRIME=1 glxinfo | grep ‘OpenGL renderer’

OpenGL renderer string: AMD Radeon RX 5600M (NAVI10, DRM 3.40.0, 5.11.1-1-MANJARO, LLVM 11.1.0)

xrandr --listproviders

Providers: number : 2
Provider 0: id: 0x55 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 4 outputs: 2 associated providers: 1 name:Unknown AMD Radeon GPU @ pci:0000:07:00.0
Provider 1: id: 0x86 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 6 outputs: 2 associated providers: 1 name:AMD Radeon RX 5600M @ pci:0000:03:00.0

Right click on the game on Steam and in the launch options type:

DRI_PRIME=1 %command%

I don’t have a AMD card,but its the same process as a nvidia card so should work for you.

Thank you, but as per my post just setting DRI_PRIME=1 did not work

Solution from this reddit thread:

Using both seems to take care of the issue generally:

DRI_PRIME=1 DXVK_FILTER_DEVICE_NAME=NAVI10 %command%

NAVI10 is the chipset/codename (?) for the AMD RX 5600M

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.